Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have remastered a Ubuntu 13.04 Live-CD for software presentations. During boot, it tries to find a network connection for several minutes (but fails in the end). Maybe it does not detect my network card properly (MacBook Pro). For the live system I don't need an internet connection. Only access to localhost is important.

How do I prevent the system from configuring the network/internet connection while still preserving access to localhost?

If I can not turn this off, is it possible to reduce the timeout for this configuration process?

EDIT: I forgot to say that I used a minimal Ubuntu 13.04 with command line only. Hence, no GUI components are responsible for the delay.

EDIT 2: The /etc/network/interfaces of the Live-DVD before remastering is

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
share|improve this question

2 Answers 2

I assume it is searching for a wireless access point. Normally, Network Manager will not look for an ethernet connection if it can't detect a cable. I suggest you determine the wireless driver from the terminal command:

sudo lshw -C network

In many MacBooks, the driver will show as b43-pci-bridge. If this is your case, you actually want b43. Blacklist the wireless driver you found:

gksudo gedit /etc/modprobe.d/blacklist.conf

Add a new line at the end:

blacklist driver

...where driver is the wireless driver you found in lshw.

Then remaster.

share|improve this answer
    
The problem might occur on other systems, too. Is there a way to blacklist all network devices? –  porst17 Aug 23 '13 at 10:31
    
In that instance, I think a more practical solution is to remove Network Manager: sudo apt-get remove --purge network-manage* and then remaster. –  chili555 Aug 23 '13 at 21:55
    
No network-manage* packages are installed since I used a minimal, command line based system. Any suggestions? –  porst17 Aug 26 '13 at 7:13
    
If Network Manager is not present, then interfaces look for their connections based on entries in /etc/network/interfaces. What does yours contain? I suggest you remove everything except the loopback entries. –  chili555 Aug 26 '13 at 11:50
up vote 0 down vote accepted

I solved it by editing /etc/init/failsafe.conf, which contained the messages and the delays:

# failsafe

description "Failsafe Boot Delay"
author "Clint Byrum <clint@ubuntu.com>"

start on filesystem and net-device-up IFACE=lo
stop on static-network-up or starting rc-sysinit

emits failsafe-boot

console output

script
    # Determine if plymouth is available
    if [ -x /bin/plymouth ] && /bin/plymouth --ping ; then
        PLYMOUTH=/bin/plymouth
    else
        PLYMOUTH=":"
    fi

    # The point here is to wait for 2 minutes before forcibly booting 
    # the system. Anything that is in an "or" condition with 'started 
    # failsafe' in rc-sysinit deserves consideration for mentioning in
    # these messages. currently only static-network-up counts for that.
    sleep 20

    # Plymouth errors should not stop the script because we *must* reach
    # the end of this script to avoid letting the system spin forever
    # waiting on it to start.
    $PLYMOUTH message --text="Waiting for network configuration..." || :
    sleep 40

    $PLYMOUTH message --text="Waiting up to 60 more seconds for network configuration..." || :
    sleep 59

    $PLYMOUTH message --text="Booting system without full network configuration..." || :

    # give user 1 second to see this message since plymouth will go
    # away as soon as failsafe starts.
    sleep 1
    exec initctl emit --no-wait failsafe-boot
end script

post-start exec logger -t 'failsafe' -p daemon.warning "Failsafe of 120 seconds reached."

Just replace the xx in sleep xx with a small value. It might also be possible to remove the sleep commands. This does not necessarily disable the network interfaces, but reduces the time for the system trying to find a connection.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.