Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently fresh-installed ubuntu 13.04.Running on Asus u43f

After running system test, my video test failed.

I have installed the latest version of Intel Driver Manager. While running this to update my drivers, it fails and the following message is displayed:

"Package libdrm2:i386 cannot be removed" The terminal output during this process is:

package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('AllowUnauthenticated', <true>)
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Status', <'status-authenticating'>)
๐Ÿ•› update_action
๐Ÿ•› Authenticating : Done  [ 100 % ] โฒ
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Progress', <9>)
๐Ÿ•› update_progress
๐Ÿ•› Authenticating : Done  [   9 % ] โฒ
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Status', <'status-resolving-dep'>)
๐Ÿ•› update_action
๐Ÿ•› Resolving dep : Done  [   9 % ] โฒ
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Status', <'status-loading-cache'>)
๐Ÿ•› update_action
๐Ÿ•› Loading cache : Done  [   9 % ] โฒ
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Dependencies', <(['fakeroot=1.18.4-2ubuntu1', 'debhelper=9.20120909ubuntu1', 'libalgorithm-merge-perl=0.08-2', 'g++-4.7=4.7.3-1ubuntu1', 'dh-apparmor=2.8.0-0ubuntu11', 'libalgorithm-diff-xs-perl=0.04-2build3', 'po-debconf=1.0.16+nmu2ubuntu1', 'g++=4:4.7.3-1ubuntu10', 'dkms=2.2.0.3-1.1ubuntu2', 'build-essential=11.6ubuntu4', 'dpkg-dev=1.16.10ubuntu1', 'html2text=1.3.2a-15ubuntu3', 'libalgorithm-diff-perl=1.19.02-3', 'libstdc++6-4.7-dev=4.7.3-1ubuntu1', 'libmail-sendmail-perl=0.79.16-1', 'libsys-hostname-long-perl=1.4-2'], @as [], ['libdrm-nouveau2:i386=2.4.43-0ubuntu1.1', 'libdrm-radeon1:i386=2.4.43-0ubuntu1.1', 'libgl1-mesa-dri:i386=9.1.3-0ubuntu0.3', 'libgl1-mesa-glx:i386=9.1.3-0ubuntu0.3', 'libdrm2:i386=2.4.43-0ubuntu1.1', 'libdrm-intel1:i386=2.4.43-0ubuntu1.1'], @as [], ['libdrm-nouveau2=2.4.45-0ubuntu1', 'libdrm-radeon1=2.4.45-0ubuntu1', 'xserver-xorg-video-intel=2:2.21.9-0ubuntu0~raring', 'libdrm2=2.4.45-0ubuntu1', 'libdrm-intel1=2.4.45-0ubuntu1', 'libva1=1.2.1-0ubuntu0~raring'], @as [], @as [])>)
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Download', <int64 14502010>)
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Space', <int64 25445376>)
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Unauthenticated', <['i915-3.9-3.8-dkms', 'i965-va-driver', 'libdrm-intel1', 'libdrm-nouveau2', 'libdrm-radeon1', 'libdrm2', 'libkms1', 'libva-drm1', 'libva-egl1', 'libva-glx1', 'libva-intel-vaapi-driver', 'libva-tpi1', 'libva-wayland1', 'libva-x11-1', 'libva1', 'vainfo', 'xserver-xorg-video-intel']>)
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('HighTrustWhitelistedPackages', <@as []>)
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Status', <'status-setting-up'>)
๐Ÿ•› update_action
๐Ÿ•› Setting up : Done  [   9 % ] โฒ
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Status', <'status-waiting'>)
๐Ÿ•› update_action
๐Ÿ•› Waiting : Done  [   9 % ] โฒ
package-manager-ubuntu.c/run_transaction_finished: APT transaction finished
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Status', <'status-running'>)
๐Ÿ•› update_action
๐Ÿ•› Running : Done  [   9 % ] โฒ
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Progress', <11>)
๐Ÿ•› update_progress
๐Ÿ•› Running : Done  [  11 % ] โฒ
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Error', <('error-not-remove-essential', 'Package libdrm2:i386 cannot be removed')>)
transaction-view.c/on_pm_op_failed: Package manager operation failed: Package libdrm2:i386 cannot be removed
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('Status', <'status-finished'>)
๐Ÿ•› update_action
๐Ÿ•› Finished : Done  [  11 % ] โฒ
package-manager-ubuntu.c/on_transaction_signal: Received transaction signal PropertyChanged from :1.105 with ('ExitState', <'exit-failed'>)
๐Ÿ•› on_transaction_signal
๐Ÿ•› Finished : Done  [  11 % ] โ—ฆ

Solution:

Ok here is what I did to fix this.

I wanted to upgrade all my packages with the sudo command. I couldn't do that because the PPA Wasn't keyed right for the download.01.org package. So looking on the website, they offered the following:

Signatures - Ubuntu*

In order to "trust" the Intelยฎ Linux Graphics Installer, you will need to add keys to Ubuntu's software package manager ("apt"). Open a terminal, and execute these line:

wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | \
sudo apt-key add -

wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 -O - | \
sudo apt-key add -

Now, to update the packages. So

sudo apt-get update

Now that we have the updates, we upgrade

sudo apt-get upgrade



 Now that probably did it, but we want to be sure. So I ran the Intel Graphics Drivers Manager. This time, it worked.
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.