Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I created the launcher for the Ranger filemanager like this:

#!/usr/bin/env xdg-open

[Desktop Entry]
Version=1.0
Type=Application
Terminal=true
Icon[pl_PL]=/
Name[pl_PL]=Ranger
Exec=/usr/bin/ranger
Name=Ranger
Icon=/home/yemu/.icons/Ranger.png

Unfortunately, the icon only shows on the .desktop file, but after I run it, in the launches there's default grey icon with gear instead of the ine defined in the file.

share|improve this question
    
Have you tried a reset of unity? or just a rebooting of your system? –  blade19899 Aug 22 '13 at 13:56
    
Try to remove the [pl_PL] entries. They are doing nothing. Also where have you saved the .desktop file? –  Salem Aug 22 '13 at 14:16
    
I have .desktop file saved in /usr/share/applications, the app shows up when I search for it in unity. but shows without the icon, in the launcher it has the grey gear icon. –  yemu Aug 22 '13 at 17:55
add comment

1 Answer

I'm self posting the answer I found on the internet, here's my desktop entry, temporarily using baobab icon, but I hope I'll manage to change that. ranger shows up as an indepentent app, and I can swith to it with Super+Number, and that's mainly the thing I wanted to achieve. Using this method I also managed to add some bookmarks to the left-click menu of this launcher.

[Desktop Entry]
Name=Ranger Filemanager
Comment=File management utility
Exec=gnome-terminal --disable-factory --sm-client-disable --class=myserver -x ranger
StartupWMClass=myserver
Icon=baobab
Terminal=false
Type=Application
StartupNotify=true
X-Ayatana-Desktop-Shortcuts=Dir1;Dir2;

[Dir1 Shortcut Group]
Name=dokumenty
Exec=gnome-terminal --disable-factory --sm-client-disable --class=myserver -x ranger /home/yemu/dokumenty
TargetEnvironment=Unity
[Dir2 Shortcut Group]
Name=wideo@optiplex
Exec=gnome-terminal --disable-factory --sm-client-disable --class=myserver -x ranger /media/optiplex/wideo

The crucial thing is to add wmclass and then set terminal as false.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.