Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 13.04 Desktop (x64) onto my Windows 8 machine. Ubuntu loads fine however, on the boot menu when I select boot Windows 8 it comes up with a series of errors:

enter image description here

I also have the error message KMV disabled by BIOS when I boot Ubuntu (though that does boot successfully afterwards).

I have heard something about secure UEFI but I do not know what that is really or how t should be disabled (if that is the issue).

My computer is a Lenovo IdeaPadZ500.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Two separate issues may be at play here.

  1. Your UEFI boot entry for Windows may be incorrectly generated. It is a known issue: update-grub generates only BIOS based menu entries for Windows, even on UEFI systems. There are several ways to fix the problem; follow the quoted thread to see which one you would prefer.

  2. Secure Boot prevents Windows 8 from being loaded from Grub2 on dual-boot systems: Unable to chainload Windows 8 with Secure Boot enabled. See if turning off the Secure Boot in your BIOS menu fixes the problem for you.

share|improve this answer
    
I have disabled secure boot and that has left only to errors “can’t find command ‘drivemap’” and “invalid EFI file path” –  user2521439 Aug 22 '13 at 14:13
    
Will the above solution fix it? (or will this tutorial simplehelp.net/2013/07/10/…) –  user2521439 Aug 22 '13 at 14:14
    
@user2521439: yes, this should fix your problem. This is yet another way to solve issue (1). –  Beef Eater Aug 22 '13 at 15:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.