Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I find this sort of issue everywhere, however I have been at this for just about two weeks and really need to fix this, as I need the functionality of my NVIDIA Geforce GT 540m.
Running an external monitor via HDMI (1920x1080) and using my laptop screen (1366x768) as my secondary screen.

My process:

Download the driver from Nvidia's site; Linux x64 for GT540m. (version 319.49) Renamed to NVIDIA.run

CTRL+ALT+F1
sudo bash
sudo service lightdm stop && sudo service gdm stop
sh /home/jake/Downloads/NVIDIA.run 
->installer launches
Accepted the license
Install NVIDIA's 32-bit compatibility OpenGL libraries? Yes
Run nvidia-xconfig utility? Yes (supposed to create a file most likely about my monitors ie. 10.monitor.xml and/or xorg.conf)
->installer complete
reboot

My issue:

Could not apply stored configuration for monitors

none of the selected modes were compatible with the possible modes:
Trying modes for CRTC 63
CRTC 63: trying mode 640x480@60Hz with output at 1366x768@60Hz (pass 0)
CRTC 63: trying mode 640x480@60Hz with output at 1366x768@60Hz (pass 1)
Trying modes for CRTC 64
CRTC 64: trying mode 640x480@60Hz with output at 1366x768@60Hz (pass 0)
CRTC 64: trying mode 640x480@60Hz with output at 1366x768@60Hz (pass 1)

The screens are very small, but I manage to uncheck the "mirror displays" and set my external monitor to 1920x1080. However, my laptop screen is stuck at 640x480, with no other options available next to forcing it via command line from terminal. (a band-aid for a festering wound only covers it up) I start up an application that requires java and/or opengl, Minecraft, of course, and it gives me org.lwjgl.LWJGLException: Could not init GLX

Any ideas?

Thanks.

UPDATE I purged my old nvidia driver, ran sudo apt-get nvidia-319. Restarted. Resolution is back to it's intended and desired settings! However: I start up nvidia xserver settings, and it gives me: You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just runnvidia-xconfigas root), and restart the X server.

I ran sudo nvidia-xconfig, rebooted, and my resolution issue returned (back to 640x480 on both screens).
Here is the xorg.conf:

nvidia-xconfig: X configuration file generated by nvidia-xconfig
 nvidia-xconfig:  version 325.15  (buildmeister@swio-display-x64-rhel04-03)  Wed Jul 31 19:04:27 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"UPDATE

        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection

    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection

    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection

    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
share|improve this question
    
Instead of downloading Nvidia version 319.49 from the Nvidia website, you could have installed the nvidia-319 package from the Ubuntu Software Center. –  karel Aug 22 '13 at 8:25

3 Answers 3

the link below is how i installed my nvidia driver. its easy to do but nvidia will always be on.

http://ubuntuhandbook.org/index.php/2013/08/install-upgrade-nvidia-319-49-ubuntu/

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Braiam Sep 5 '13 at 11:16

The simplest way to ensure best possible performance with NVIDEA cards is to install the Steam client from valve and ask it to run Team Fortress 2 (huge download but free).

It then guides you to get your NVIDEA card up and running with the latest drivers good enough for gaming.

(You may get the diagnostics without downloading the game, but I am not certain).

share|improve this answer

Unfortunately if your using a mobile nVidia on a laptop (the "m" after the graphic card name) it usually means it's an "Optimus" nVidia card. Optimus is an nVidia technology used on laptop for saving energy: the concept at its core is that when you're not using accelerated applications the integrated non-accelerated video chip (usually an Intel graphic card) is used, while the nVidia GPU is turned on only when necessary.

Problem is that nVidia still does not really support Optimus technology on Linux: simply installing the nVidia drivers as you tried to do won't work because of the hardware architecture of this "hybrid" nVidia cards.

One thing you can do is use Bumblebee which enables Optimus support on laptops (see https://wiki.ubuntu.com/Bumblebee) and should help with dual-monitor configuration (see http://blog.linuxacademy.com/linux/ubuntu-bumblebee-optimus-and-multi-monitor-support/)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.