Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

So, after learning that in order to boot into Ubuntu from a usb drive, I had to go into my bios and change the boot setting from UEFI to Legacy, I managed to install Ubuntu 13.04. Now, when I restart my laptop, it pops up the GRUB menu thing, and I can load Ubuntu no problem. But if I try to select Windows, I get an error saying windows can't be booted, and I need the recovery disc to repair this. but, since I don't have one, I thought it'd be a good idea to look around the boot settings again. Changing the boot settings from Legacy back to UEFI lets me boot into windows normally, but there is no option to get into Ubuntu unless I change it back to Legacy, which locks me out of Windows again. My question is, how can I make these options bot available to me without having to mash f2 to get into the bios every time I want to change my OS? Thank you in advance.

share|improve this question
    
Hi Bryce. The problem you are having is in the Troubleshooting section under "Dual Boot issues". It is basically a minor mistake you took when installing Ubuntu. You need to install Ubuntu with UEFI support because Windows was installed with it. If you wish to use both on the same boot menu, you need to stick with the boot options that Windows had (UEFI, Secureboot...). –  Luis Alvarado Apr 16 at 18:13
add comment

marked as duplicate by Luis Alvarado Apr 16 at 18:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

Although the symptoms are slightly different, the solution I offered to this question is likely to work for you.

share|improve this answer
add comment

I have Ubuntu 12.04 running alongside windows 8.1 with no problems. I created the Ubuntu USB boot pen then, from within windows, I clicked restart while holding down shift. This presents different troubleshooting options. I selected boot from USB pen and the machine rebooted from the USB pen. In the BIOS settings (OK UEFI settings, I can't help saying BIOS as a generic term) boot mode was set to UEFI. As stated above, you can't mix the boot modes between operating systems. Hope this helps.

share|improve this answer
add comment

try using these recovery disks

alternatively you can use EasyBCD (Easy Boot Configuration Data) and chain load grub. This guide shows you how to use it.

share|improve this answer
    
This problem is caused by a mixed-mode (Windows in EFI, Linux in BIOS) installation. As such, running a Windows fix-it utility will not help. Furthermore, the last I heard, EasyBCD is useless for managing EFI-mode dual-boot installations. –  Rod Smith Aug 21 '13 at 23:45
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.