Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Background

I have a dell inspiron 15r se. Step by step, I wanted to upgrade the system from 11.10 to 13.04. Up to 12.10 everything was alright, it was working very well,

Problem

When i did sudo do-release-upgrade from 12.10 to 13.04, after the upgrade unity was not working, I had only desktop visible, no menu on top or left (i am not sure how they are called). I had exactly this.

What I tried

Of course I tried resetting unity, enabling unity plugin in compiz, etc, but nothing worked.

At this moment I don't really remember what I have done (I tried many different things like until 2 am in the night, i can't recall all) and now what I get is the "Low Graphics Mode" just like in here. My graphics card is ATI, so I tried the solution offered here, and absolutely nothing changed.

I also tried installing linux-headers-generic, also linux-headers-'uname -r', adding a symbolic link for version.h (because it wasn't there, i did something like that) but none of them worked.

Starting using one of the old kernels (selecting them from GRUB) does not work either, each one of them also go into low graphics mode.

Here is the output from my /var/log/Xorg.0.log

Any help is appreciated!

share|improve this question
    
for the record, I couldn't find any solution and I had to use recovery partition to go back to 11.10. –  Hayri Uğur Koltuk Oct 9 '13 at 21:04
    
I do not know about the model (Dell Inspiron) so please let me know if it is a 64 bit processor and if there was a linux-generic-pae installed on your system. If yes, then it has been seen to happen quite frequently in our systems. –  Indian Oct 20 '13 at 12:00
    
However, in case if you find a failsafe kind of file in /etc/X11 manage to delete that file by booting to command prompt and all will be well. –  Indian Oct 20 '13 at 12:02
add comment

1 Answer

Had the same problem after upgrade to the latest ubuntu. I copied the system files from a laptop onto a spare disk. Did a chroot from a rescue disk and fixed grub. Booted from a usb port on my old intel box for which there are no drivers. ctl+alt+f1 gave me a shell. in /etc/lightdm/lightdm.cfg found autologon for user. Disabled it by inserting # at start of line. ran dpkg-reconfigure lightdm ran service lightdm restart This gave me a logon screen. Changed the session to the top option (I think gdm) and was able to logon. Logged out and changed the session back to ubuntu unity. Peter

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.