Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just a heads up, I'm brand new to ubuntu and linux as a whole, so go easy on me.

I just installed ubuntu 13.04 on my Thinkpad T430. A few bumps along the way, but I'm learning this new system quickly.

I have two external monitors plugged in through the dock I have for the laptop, plus a USB-to-DVI adapter that is functioning properly. However, when I dock my laptop, the laptop monitor itself shuts off and I only get the 3 external. I'd like to have all four monitors working at once.

When I go into Display under System Settings, and turn on the laptop monitor, I get a timeout error.

Normally I would say this is a video card problem, but last week I was running 12.04 and everything was working properly. I did clean reinstall.

Hopefully you guys can help me out, thanks!

EDIT:

Super + P and/or FN + F7 (Monitor Hotkey) cycles between the following:

  • Laptop monitor only
  • Mirrored on external monitors (laptop monitor is off)
  • 3 External monitors extended view (laptop monitor is off)

In Additional Drivers, it only says "no proprietary drivers in use". There are no options in the window to choose any different drivers, and there are none listed.

share|improve this question
    
Does Super+P do anything? (you might know the Super key as the Windows key) Also what driver are you using? (Look for Software & Updates and then in the Additional Drivers tab) –  Gerhard Burger Aug 21 '13 at 20:19
    
Super+P cycles between: Laptop monitor only, mirror across all three external monitors (laptop monitor off), and all 3 monitors extended (laptop monitor off). –  Moses Aug 26 '13 at 16:47
    
In Additional Drivers, all it says is that I'm "not using any proprietary drivers". There are no options in the window, for X-server or otherwise. –  Moses Aug 26 '13 at 16:48
    
If you disconnect the Usb-to-Dvi adapter along with it's external monitor, can you then enable the laptop display for both mirrored and extended view on the Display panel without the timeout error. Set your Display panel on 13.04 where Super+P cycles between: Laptop monitor only, mirror across two of the three external monitors (laptop monitor on), and two of the three monitors extended (laptop monitor on). –  LantzR Aug 30 '13 at 20:11
add comment

3 Answers 3

up vote 2 down vote accepted
+50

Your question explained:

  • last week I was running 12.04 and everything was working properly
  • I just installed Ubuntu 13.04
  • when I dock my laptop, the laptop monitor itself shuts off
  • When I go into Display under System Settings, and turn on the laptop monitor, I get a timeout

I am sorry that your fascinating four monitor setup, that was working on 12.04 LTS [3] Precise is no longer working on 13.04 Raring. You have found a bonafide bug in 13.04 Raring. You should submit this as a bug report [1] on the collaboration hub called LaunchPad [2] where developers can work to fix it. This is not the best forum to collect all the details of your setup, plus the people you really need to look at the issue are working out of the queues on Launchpad.

Now I'd love to tell you one configuration tweak or a command to run but here's the thing.

One of the differences [4] between a normal release like 13.04 Raring, and a LTS release [3] like 12.04 LTS Precise or next years 14.04 LTS "Tranquil Tiger" [5] is a focus on supporting new kinds of desktop hardware, especially when coordination across multiple packages is required.

You are running something like this:

  • Lenovo Thinkpad T430 Laptop
  • one Graphics adapter in laptop
    • Intel HD Graphics 4000
  • Docking station
    • [assumption] Lenova ThinkPad Mini Dock Series 3
  • Usb-to-Dvi graphics adapter
    • [assumption] Lenova Usb-to-Dvi Monitor Adapter
    • [assumption] Windows Plug and Pray Device
    • [assumption] DisplayLink (libdlo) technology [8]
  • Monitors
    • one monitor inside the laptop
    • two external monitors plugged in through the dock
    • one external monitor plugged in through a Usb-to-Dvi graphics adapter

After you submit your bug report [1], I have some things for you to consider and then a couple of suggestions.

When X11 was born there was one graphics card per monitor.

Traditionally in X11, a SCREEN had a one-to-one correspondence with a physical display device
(a monitor) [7]

This comment is about a different problem that is in the same problem space.

... everything related to multiple monitors or multiple terminals on Linux right
now is very distro dependent (and spins within distros). Frankly, it's a disaster.
It's not just GDM vs. KDE, but also systemd vs. sysvinit, X vs. Wayland,
fbdev vs. DRM, etc, etc.. The APIs and UIs are completely balkanized,
and combinations that do work are very version dependent.[6]
-- Bernie Thompson - May 2013

Some other issues:

  • DisplayLink
    • libdlo
  • X vs Mir
  • Wayland vs Mir
  • X vs Quartz
  • Microsoft Plug and Pray

So while just allowing your laptop screen to rest, is probably not your preference, I would try removing the Usb-to-Dvi Graphics dongle. While that will turn off that external monitor it may re-enable your laptop monitor. That would at least give a choice of which of your monitors gets a vacation.

You can try 13.10 Saucy Salamander in just a few weeks when it is released on the October 17th 2013 and see if your problem has been fixed. If it has been fixed in 13.10 Saucy, you will then get to choose to if you want to install 13.10 Saucy or wait to see if the developers are able to backport the fix to 13.04 Raring.

Ok, so do you remember this line.

  • last week I was running 12.04 and everything was working properly

I suggest you re-read that line a couple more times and realize that going back to 12.04 Lts Precise[9] may be your best option before 14.04 LTS "Tranquil Tiger" [5] is released.

Cheers,
Lantz


References:


share|improve this answer
    
@moses I am interested in confirming my assumptions as well as if you tried to disconnect the Usb-to-Dvi adapter. There are a couple more options I will try to get added today. –  LantzR Sep 3 '13 at 23:52
add comment

If you have an nvidia or AMD graphics card, you should try installing the proprietary drivers. To install them you should go into Software & Updates and then in the Ubuntu Software tab. Make sure Proprietary drivers for devices is checked. If that doesn't bring up the drivers in the Additional Drivers tab, you should try the following:

sudo apt-get update

followed by the appropriate command to install your driver:

sudo apt-get install nvidia-current

for an nvidia card or

sudo apt-get install fglrx fglrx-amdcccle

if you have an AMD card.

share|improve this answer
    
My laptop has an Intel HD Graphics 4000 card. –  Moses Aug 31 '13 at 20:01
add comment

There should be an F key that has an icon of two monitors, in my case F4. Try with the combination of Fn (function) key and the F key, according to your keyboard.

share|improve this answer
    
The FN + F7 is mapped for this in my case, but for my system, it simply replicates the behavior of Super + P. Same results with either method as in the edit in my question. –  Moses Aug 30 '13 at 19:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.