Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

So I just got a brand new Dell XPS 13 which comes preinstalled with Windows 8 Pro. I decided to install Ubuntu 13.04 and dual-boot. I made a bootable USB, booted up the Ubuntu installer and found that it didn't recognise my Windows 8 OS to install "alongside", so I realised I would need to make my partitions manually. I went back into windows and used the disk manager to shrink my C drive by 100GB. There were about 5 other partitions like EFI and stuff that I ignored. Then, back to the ubuntu installer, made a primary partition of ext4 and a 20Gb Swap partition. I finished the installer, and Ubuntu works great!

Now my problem. I have no way of booting Windows. Every time I start the machine, it goes straight into Ubuntu. I have tried holding down Shift, but don''t see any GRUB screen. Ubuntu works great, but how do I boot to Windows???

share|improve this question
    
I made a mistake and voted this as a dupe, I apologize. To close voters: ignore my close vote. –  Thomas W. Aug 21 '13 at 16:52
add comment

marked as duplicate by Luis Alvarado Apr 16 at 18:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

up vote 0 down vote accepted

Reboot your laptop and enter in your boot menu with F12.
Now look for Windows 8 boot option and select it if it's there.

PS: This solved my problem

share|improve this answer
    
Thankyou so much! I thought I had tried everything, so I was so excited to see a boot menu when I hit F12. Boots into Windows perfectly... –  Christopher Gillis Aug 23 '13 at 4:04
    
Now I just need to figure out how to show the menu by default... any ideas? –  Christopher Gillis Aug 23 '13 at 4:05
add comment

There are at least two possible causes of your problem:

  • You've installed Ubuntu in EFI mode but the GRUB configuration tool has failed to identify Windows, and so is booting through GRUB but with a short timeout and a hidden menu.
  • You've installed Ubuntu in BIOS mode, which means that it can't boot Windows (which is in EFI mode), and so GRUB is using a short timeout and a hidden menu.

If you're booting in EFI mode, this might be a bit easier to fix, since you should be able to run Boot Repair from your current Ubuntu and it should be fixed. To determine if you're in EFI mode, look for a directory called /sys/firmware/efi. If it's present, you're booting in EFI mode; but if it's absent, you're probably booting in BIOS mode.

If you're booting in BIOS mode, you can fix the problem by installing an EFI-mode boot loader for Linux. You can do this in any of several ways, but two relatively easy ones are:

  • Boot a live CD-R or USB flash drive in EFI mode and run Boot Repair. This should get GRUB up and running with Windows detected. The trick is forcing an EFI-mode boot of a live CD. You may need to play with your firmware's boot options. Typically, hitting a function key (which one varies) produces a boot menu, and you should select the one for your live CD that mentions "EFI" or "UEFI."
  • Download the CD-R or USB flash drive image of my rEFInd boot manager and prepare a medium with it. You should then be able to boot to it. If rEFInd lets you boot both Windows and Linux, boot to Linux, mount your EFI System Partition (ESP) to /boot/efi, and install the Debian-package version of rEFInd. You'll then use rEFInd to select your OS on subsequent boots.

If one of these fails, try the other one. If you continue to have problems, post back with the URL that Boot Repair provides; this will give us detailed information on your system's configuration.

share|improve this answer
    
Hi Rod Smith. The directory /sys/firmware/efi IS present. I've heard scary things about Boot Repair, so wanted to find an easy solution before trying that. @Deus suggested F12, which DOES show the Boot Menu. How do I get that to display by default? –  Christopher Gillis Aug 23 '13 at 4:08
    
The boot menu you get by hitting F12 is provided by the firmware. AFAIK, few or no EFIs enable this to be brought up by default; you must always use F12 (or other keys, depending on the firmware) to access it. To get something equivalent, you must install a boot manager like rEFInd or gummiboot on the computer. –  Rod Smith Aug 23 '13 at 16:49
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.