Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did a fresh install of 13.04, after hearing great comments from people. The experience was great overall, but the only problem I have is that while rebooting, a black terminal-styled reboot comes up. All tasks had [OK] checked behind it, I'm just stuck on the "Restarting system..." so I ALWAYS have to do a hard reboot using power button. However, shutdown works just fine.

I am using a 64-bit Windows 7 dual boot config and using a Acer Aspire V3-471G. Any answer or solution will be greatly appreciated.

share|improve this question
    
as long as you don't have this problem solved, you can reboot with magic SysRq and typing [r], [e], [i], [s], [u], [b]. This way you won't have to hardware reset your machine. See more on this here: en.wikipedia.org/wiki/Magic_SysRq_key#Uses –  onse Aug 21 '13 at 11:50
    
@onse This partially solved my problem, but is there any way that you can reboot from the UI and not using SysRq? –  yan3321 Aug 21 '13 at 12:12
    
there should be. This is just a workaround so that your machine does not get damaged by hardware resetting. The problem is that there can be many reasons why this happens. I would advice you to check your /var/log/syslog and /var/log/kern.log to see if any errors are being logged when the system won't reboot. –  onse Aug 21 '13 at 12:28

1 Answer 1

You can try this :

at terminal :

sudo nano /etc/default/grub

Find the line:

GRUB_CMDLINE_LINUX=””

and replace it by this line:

GRUB_CMDLINE_LINUX=”reboot=efi”

Save the changes and close the file.

sudo update-grub

Then try to restart.

Found this solutions at this website :

https://sites.google.com/site/easylinuxtipsproject/bugs#TOC-Reboot-fails

share|improve this answer
    
Sorry, I forgot to update. it should be : GRUB_CMDLINE_LINUX=”reboot=bios” –  Chris Nov 30 '13 at 16:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.