Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've noticed (using nethogs), that /usr/lib/apt/methods/http has multiple processes, which consume ALL of my bandwidth. I want to disable the process(es).

I've tried everything: trickle, killall, etc., but nothing has worked.

How can I solve this problem?

share|improve this question
When and for how long? – Oli Apr 4 '11 at 22:48

2 Answers 2

apt does have (or at least, did have) configurable options for this. Run this from a terminal.

sudoedit /etc/apt/apt.conf.d/76download

And paste in the following:

    Queue-mode "access";
        Dl-Limit "50";

That will limit apt-get (over HTTP) to 50KB/s but just change the Dl-Limit value to whatever suits your circumstances best. Save the file and you're done.

share|improve this answer

Probably the software updates are downloaded in the background, you can disable this feature in the settings of the Update Manager.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.