Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I am trying to convert a wmv video to mp4 using h264 baseline profile.

avconv -i 'Video2.WMV' \
-vcodec libx264 -preset ultrafast -profile baseline \
-acodec aac -strict experimental \
-r 24 -b 255k -ar 44100 -ab 59k 'Video2.mp4'

But it is showing following errors:

[aac @ 0x707e40] [Eval @ 0x7fff0c8db800] Undefined constant or missing '(' in 'baseline'
[aac @ 0x707e40] Unable to parse option value "baseline"
[aac @ 0x707e40] Error setting option profile to value baseline.

Profile setting is causing the errors. If I run the command:

avconv -i 'Video2.WMV' \
-vcodec libx264 -preset ultrafast \
-acodec aac -strict experimental \
-r 24 -b 255k -ar 44100 -ab 59k 'Video2.mp4'

Then it works fine.

What is the correct method of setting h264 profile in avconv command? Running Ubuntu 13.04 and latest libavtools

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Try with:

avconv -i 'Video2.WMV' \
-vcodec libx264 -preset ultrafast -profile:v baseline \
-acodec aac -strict experimental \
-r 24 -b 255k -ar 44100 -ab 59k 'Video2.mp4'

-profile:v ensures the baseline profile is applied to video only

share|improve this answer
    
Thanks! it worked :) –  Junaid Aug 21 '13 at 10:16
add comment

The -profile switch is depreciated, and was replaced by the -vprofile due some naming conflict, since the aac audio profile option use the same option. The fix is use -vprofile:

avconv -i 'Video2.WMV' \
-vcodec libx264 -preset ultrafast -vprofile baseline \
-acodec aac -strict experimental \
-r 24 -b 255k -ar 44100 -ab 59k 'Video2.mp4'

Source: http://trac.ffmpeg.org/ticket/387

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.