Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop computer has a Nvidia video card and runs Ubuntu 12.04 LTS 64-bit. During an upgrade yesterday it seemed as a new Nvidia driver version 304 (if I remember correct) was installed. After upgrade and reboot, I opened the Additional Driver tool and found that the Nvidia driver version 304 was in use. So far so good.

However, the Additional Driver tool also reported that there existed a Nvidia driver version 319 and that this driver version was recommended. I then selected to change to this recommended driver, the driver was downloaded and installed, I rebooted the system and ended up with a black screen and a command shell.

How to change proprietary Nvidia video driver using the command line and revert back to the previous version that worked on my system?

(A second question: How can it be that a video driver that apparently does not work was recommended?)

share|improve this question

3 Answers 3

up vote 8 down vote accepted

You can use jockey-text to disable and enable Nvidia drivers in Ubuntu.

For example:

  • Run jockey-text --list to get the list of available options.

  • Run sudo jockey-text -d xorg:nvidia_304 to remove the 304 driver.

  • Run sudo jockey-text -e xorg:nvidia_304 to enable the same driver.

  • Run jockey-text --help to see the help manual.

share|improve this answer
1  
what about in 13.10? I don't have a tool called jockey. –  northben Feb 24 at 14:23
    
jockey-text is provided by jockey-common: sudo apt-get install jockey-common –  bacon Feb 24 at 17:30
3  
14.04 (maybe 13.10 also) replaced jockey-common with ubuntu-drivers-common which has the ubuntu-drivers executable that works differently. –  Nick T Jul 23 at 23:01

I had the same problem using 304/319 drivers from repositories, Nvidia has proprietary drivers on their website, installed from there they actually work quite well, I used this manual to remove remaining drivers and install the correct one directly from Nvidia.

http://www.beginninglinux.com/home/graphics-drivers/install-nvidia-custom-driver-on-ubuntu-12-04

Make sure you pay attention to everything, especially make sure that in /etc/default/grub line GRUB_CMDLINE_LINUX_DEFAULT contains nomodeset, otherwise Nvidia driver does not work.

Also if proprietary drivers do not work and you are stuck in command line, you may always uninstall Nvidia drivers and install the default nouveau driver.

$ sudo apt-get auroremove --purge nvidia-*
$ sudo stop lightdm
$ sudo apt-get install xserver-xorg-video-nouveau
share|improve this answer

You can also download the .sh file from nvidia then follow the steps:

  • First press control+alt+f1 - to exit GUI mode

    • sudo service gdm stop (on ubuntu)
    • navigate to the folder you downloaded nvidia drivers
    • ./nvidia.drivers.sh
    • sudo reboot after install
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.