Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was installing fbreader in Ubuntu 12.04, but it showed that some packages are broken and have unmet dependencies, so fbreader wasn't installed. Moreover, software center started to show repair package catalogue dialogue, but when I tried to repair, nothing happened. I am unable to install anything because of the error. I tried sudo apt-get autoremove and then sudo apt-get -f install, but didn't help. When I run sudo apt-get autoremove, the following are shown in the terminal:

The following packages have unmet dependencies:
 fbreader : Depends: libzlcore0.12 but it is not installed
 libzltext0.12 : Depends: libzlcore0.12 (= 0.12.10dfsg-6) but it is not installed
 libzlui-qt4 : Depends: libzlcore0.12 (= 0.12.10dfsg-6) but it is not installed

Please help.

When I tried to do repair via the software center, follwoing error report was given:

installArchives() failed: perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 228249 files and directories currently installed.)
Unpacking libzlcore0.12 (from .../libzlcore0.12_0.12.10dfsg-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libzlcore0.12_0.12.10dfsg-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/libzlcore.so.0.12.10', which is also in package libzlcore 0.12.10-1
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libzlcore0.12_0.12.10dfsg-6_i386.deb
Error in function: 
dpkg: dependency problems prevent configuration of libzltext0.12:
 libzltext0.12 depends on libzlcore0.12 (= 0.12.10dfsg-6); however:
  Package libzlcore0.12 is not installed.
dpkg: error processing libzltext0.12 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libzlui-qt4:
 libzlui-qt4 depends on libzlcore0.12 (= 0.12.10dfsg-6); however:
  Package libzlcore0.12 is not installed.
dpkg: error processing libzlui-qt4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of fbreader:
 fbreader depends on libzlcore0.12; however:
  Package libzlcore0.12 is not installed.
 fbreader depends on libzltext0.12; however:
  Package libzltext0.12 is not configured yet.
 fbreader depends on libzlui-qt4 (>= 0.12.10dfsg-6) | libzlui-gtk (>= 0.12.10dfsg-6); however:
  Package libzlui-qt4 is not configured yet.
  Package libzlui-gtk is not installed.
dpkg: error processing fbreader (--configure):
 dependency problems - leaving unconfigured
share|improve this question
    
How are you installing? –  Mitch Aug 21 '13 at 8:24
    
I installed according to the instructions given in the website ubuntugeek.com/… –  Bishwarup Paul Aug 21 '13 at 8:25

1 Answer 1

The instructions in the link in the comment install fbreader from debian. Since fbreader is in ubuntu you can simply use the Ubuntu Software Center application to find and install it and all of the dependencies.

It shows that you have libzlcore0.12 installed already and the install is failing trying to install it again.

You have two options. 1) attempt to install the dependencies 1 by 1 or 2)first remove libzlcore0.12 by using sudo apt-get remove libzlcore0.12 then remove the lines that you added from the ubuntu geek website, then run the ubuntu software center application and install from there.

As an aside for what it is worth, fbreader installed w/o error for me on my up to date ubuntu 12.04 32 bit installation.

share|improve this answer
    
I tried to remove libzlcore0.12, but the following was shown: Package libzlcore0.12 is not installed, so not removed You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: fbreader : Depends: libzlcore0.12 but it is not going to be installed libzltext0.12 : Depends: libzlcore0.12 (= 0.12.10dfsg-6) but it is not going to be installed libzlui-qt4 : Depends: libzlcore0.12 (= 0.12.10dfsg-6) but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). What should I do? –  Bishwarup Paul Aug 23 '13 at 15:48
    
I solved the problem myself by purging the individual packages one by one: sudo dpkg -P fbreader sudo dpkg -P libzlui-qt4 sudo dpkg -P libzltext0.12 sudo dpkg -P libzlcore sudo apt-get autoremove sudo apt-get update && sudo apt-get upgrade –  Bishwarup Paul Aug 25 '13 at 7:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.