Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Both CompizConfig and the Nvidia X Server settings have options to enable Sync to VBlank. By enabling the Benchmark option in Compiz I can see that ticking "enable sync to vblank" under General in Compiz will keep the Frames to 30 per second. Unticked, it is about 60. However, choosing the equivalent option in the OpenGL tab of Nvidia X settings doesn't seem to have any effect. Which option(s) should I enable?

share|improve this question
    
I just ran glxgears with compiz sync to vblank , in turn, on and off and nvidia off and the framerates were huge. Once I turned the nvidia sync to vblank on the framerate came back down to the monitor refresh rate. –  daithib8 Jul 18 '11 at 10:44
    
According to the above comment, I would have thought that any tearing (which I hadn't really noticed til then) would be non-existent with sync enabled in nvidia. But just now after becoming aware of tearing in mplayer with vdpau output I enabled sync in compiz too and that fixed it. To re-iterate, regardless of whether sync is enabled in compiz, I get 301 frames in 5 seconds in glxgears, yet I get tearing if sync is off. –  daithib8 Jul 20 '11 at 14:27

1 Answer 1

It appears that when you are using Compiz, Nvidia X Server settings' Vblank option does not work. If you are using Compiz then select the sync to VBlank in the Compiz Settings. Otherwise use Nvidia's setting. VBlank is useful for watching videos and playing games if you experience "screen tearing" which is horizontal lines occasionally distorting your video. Enabling Sync to VBlank will usually fix the screen tearing issues.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.