Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to 13.04 and afterwards the sound wasn’t working. When I look in the sound applet the only device listed is Dummy Output. I have looked online and I tried a couple solutions with no luck. I believe my sound card is being detected by the kernel but it isn't being used.

lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
    Subsystem: AOPEN Inc. Device 0501
    Flags: bus master, fast devsel, latency 0, IRQ 44
    Memory at d8200000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03) (prog-if 00 [Normal decode])

Here are the solutions I have tried:

Solution #1: Didn't work

sudo gedit /etc/default/speech-dispatcher

Changed RUN=yes to RUN=no

Rebooted

Solution #2: Didn't work

sudo alsa force-reload

Reboot

Solution #3: Didn't work

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo alsa force-reload

Reboot

Solution #5: Didn't work and my NIC and mouse stopped working

sudo apt-get install linux-image-3.8.0-19-generic

Reboot

Solution #6: Appears to work

I had version 3.2.0-51 of the kernel installed from when I ran 12.04, the last time the sound worked, so I rebooted and use grub to selected this version, Now my sound works and the NIC and mouse still work.

Additional Info: My sound card is an on-board sound card, so the motherboard is an Aopen i915Pa-E R1.00.

pulseaudio --check

returns nothing

pulseaudio --dump-conf
### Read from configuration file: /etc/pulse/daemon.conf ###
daemonize = no
fail = yes
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
allow-module-loading = yes
allow-exit = yes
use-pid-file = yes
system-instance = no
local-server-type = user
cpu-limit = no
enable-shm = yes
flat-volumes = no
lock-memory = no
exit-idle-time = 20
scache-idle-time = 20
dl-search-path = /usr/lib/pulse-3.0/modules
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target = auto
log-level = notice
resample-method = speex-float-1
enable-remixing = yes
enable-lfe-remixing = no
default-sample-format = s16le
default-sample-rate = 44100
alternate-sample-rate = 48000
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 8
default-fragment-size-msec = 10
enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 1
deferred-volume-extra-delay-usec = 0
shm-size-bytes = 0
log-meta = no
log-time = no
log-backtrace = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-rss = -1
rlimit-as = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 1000000

amixer -c 0
Simple mixer control 'PCM',0
  Capabilities: pvolume penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 223 [87%] [-6.40dB]
  Front Right: Playback 223 [87%] [-6.40dB]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65
  Mono:
  Front Left: Playback 59 [91%] [24.00dB] [off]
  Front Right: Playback 59 [91%] [24.00dB] [off]

pacmd dump-volumes
Welcome to PulseAudio! Use "help" for usage information.
Sink 0: reference = 0: 100% 1: 100%, real = 0: 100% 1: 100%, soft = 0: 100% 1: 100%, current_hw = 0: 100% 1: 100%, save = no
Source 0: reference = 0: 100% 1: 100%, real = 0: 100% 1: 100%, soft = 0: 100% 1: 100%, current_hw = 0: 100% 1: 100%, save = no
share|improve this question
    
Welcome to Ask Ubuntu! Could you edit your question and provide more details? Like the Sound Card you are using? The output of pulseaudio --check, pulseaudio --dump-conf, amixer -c 0, pacmd dump-volumes and pactl. –  Braiam Aug 21 '13 at 1:19
    
I have this same issue. For me, sudo alsa force-reload works untill the next reboot. Is this what you mean under 'Solution #2'? –  Jory Geerts Aug 21 '13 at 9:56
    
No, for me none of the solutions I have tried so far have worked at all. –  user185876 Aug 22 '13 at 8:57

1 Answer 1

Check this out:
http://alsa.opensrc.org/Quick_Install

And this one too:
http://www.linwik.com/configuring_the_audio_and_updating_alsa_for_ubuntu_12.04

If your alsa still not working try to use alsamixer by terminal and configure your sound card.
Hope it helped.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.