Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my current desktop is supported 3 language pack: English, Russian and Ukrainian.

But when another users is going to his account works only one - English.

And any choice to change language or install new language pack.

I tried did this through:

sudo apt-get install language-support-ua

or according this manual deb Linux: How to add support for Bulgarian, Russian, Belarusian, Ukrainian, Serbian, Macedonian, Bosnian language cyrillic localization to Xfce, GNOME, KDE Desktop.

But resalt always looks like next:

nazar_art@nazar-desctop:/home/andriy$ sudo aptitude install language-support-ru
Couldn't find any package whose name or description matched "language-support-ru"
Couldn't find any package whose name or description matched "language-support-ru"
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 14 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

nazar_art@nazar-desctop:/home/andriy$ apt-get install language-pack-ua
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
nazar_art@nazar-desctop:/home/andriy$ sudo apt-get install language-pack-ua
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package language-pack-ua
nazar_art@nazar-desctop:/home/andriy$ sudo apt-get install --yes language-pack-uk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
language-pack-uk is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.
nazar_art@nazar-desctop:/home/andriy$ 

Why this happen?
When I'm going as root all 3 language are active but from another account only one by default and any chance to changing it. Furthermore, doesn't exist language flag at the right up corner.

  • How to solve this trouble?
  • Or how to make language support accessible for all users?
share|improve this question
add comment

3 Answers 3

There are two places where language settings for a user are handled.

  1. From account settings, where you (as administrator) can set the default language for any user (even after the user existed and worked for some time) enter image description here

  2. For every user individually via Language settings, where he can drag his preferred language to the top (Everything below English gets ignored) enter image description here

share|improve this answer
    
I did this this change language for menus and prompts. But keep losing choose language... –  nazar_art Sep 2 '13 at 21:14
add comment

I don't know if this will help or not, but when I select System Settings > Language Support, then the attached screen is displayed. There is an option to Apply System wide. That should make the languages available to all users.

This might solve your problem. Please note that you need to be signed in as a user who has administrative privileges.

Hope this helps,

enter image description here

share|improve this answer
    
I found this, of course, but this didn't change situations. It keeps working without opportunity to change language for another users. How can change this? –  nazar_art Aug 29 '13 at 21:32
    
How to lunch this as admin user (I opened easy from dash home)? –  nazar_art Sep 2 '13 at 21:15
add comment

Only Lucid use language-support-* packages. From Precise onwards you need to use language-pack-*:

sudo apt-get install language-pack-ru

This is a package available from Lucid onwards.


nazar_art@nazar-desctop:/home/andriy$ apt-get install language-pack-ua
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

This is because you are not running as root. You need to use sudo.


language-pack-uk is already the newest version.

You already have the latest UK english language pack.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.