Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have an Ubuntu based distro (ElementaryOS)12.04 and I'm having an issue where I can't update the system nor can install any apps. Basically I can't do anything with it!

Before this I simply got an error at every time an installation finished, but the app installed anyway.

Now I am a newbie so I can't what went wrong that well, but I remember it complained about the kernel image verification "linux-image-3.5.0-18-generic needs to upgrade but failed to install". At a later stage then it wouldn't install any app at all, and every time I tried, it wanted to install this "linux-image-3.5.0-18-generic", even when removing apps, actually everything I needed to do, started downloading that ^ which is about 12.1mb. Than .deb went in var/cache/apt/archives

This "linux-image-3.5.0-18-generic" never installed always gave me error at the end! Also I remember it complained about dependencies in the same error.

Then I thought of removing all the ppa's that I added after I installed eOS. That resulted in the following problem where I can't do anything, it doesn't even download the .deb anymore, and every time I open update manager it gives me this error and closes.

E:The package linux-image-3.5.0-18-generic needs to be reinstalled, but I can't find an archive for it.

I don't understand why I needed to upgrade/install 3.5.0-18 when my kernel is , "Kernel Linux 3.10.7-031007-generic" which is newer and Is the only kernel in my linux!

I added/checked all ppa's back and same error. Can someone help? Sorry If I sound too noobish.Thnx in advance!

share|improve this question

closed as off-topic by Alvar, Bruno Pereira Aug 20 '13 at 20:35

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Alvar, Bruno Pereira
If this question can be reworded to fit the rules in the help center, please edit the question.

Welcome to Ask Ubuntu! Most questions about non-official Ubuntu derivatives are classified as off-topic. This isn't the correct Stack Exchange site to ask questions about non-official Ubuntu distributions (see the help center). However, it would be on-topic at the Unix & Linux Stack Exchange. –  Seth Aug 20 '13 at 20:38
maybe you should provide more details about the error, or the original error body. –  NKN Aug 20 '13 at 20:40

1 Answer 1

Try this first:

sudo apt-get install -f
sudo apt-get clean
sudo apt-get update

Then re-install the package.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.