Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yes, I was watching a WebM video. Specifically the recent LinuxActionShow "review" of Elementary OS Luna. And about 8 or 9 minutes into the video. The sound just cut out completely. And now no sound plays at all. MP3 files, Ogg sound files, any movies of any format. No game sounds nothing.

Restarting does not fix it, and Pulse Audio settings are all as they should be. And yes I tried changing them and switching around just to see if it might do anything. NOTHING.

So to make sure my speaker were not busted, I installed Elementary OS on a thumb drive, plus I wanted to try it anyway. Sound worked just fine with not settings changes. So I wanted to go ahead and finish watching the LAS review of E-OS, so I went into my system's drive and install necessary drivers. And it worked find and sound was good. Until part way through it happened again. And I don't think it was at the same time mark either. But since I made a persistence on this Live thumb drive, rebooting into Elementary OS as a Live instance also doesn't bring sound back. Its just gone. No MP3 sound, OGG sound or anything.

To me, this can not be a BIOS hardware setting since nothing was changed before booting into the Live USB. But anything settings should be reflected in Pulse Audio or other Sound menus right?? or is there a deeper "Kernel" setting I need to be aware of?

This is a very concerning issue, and the only way I see to fix it so far, is reinstall, and I will wipe a 2 year old install just because of sound, especially if its something that will probably happen again. I can add screen shots of my Sound settings if need be, but I am very familiar with what they are normally and like I said, I was no where near the keyboard or mouse when this began. Just a instant cut out of all sound.

Thank you and God Bless.

Update I tried headphones and they work fine. The Sound settings are updated to reflect the "Headphone" status. But if I manually in switch back to "Speakers" in settings, leaving the headphones plugged in. The sound stays coming out the headphones despite the change. Uplugging the headphones stops all sound again and nothing is muted. This is extremely strange.

Update #2 I'm sorry RolandiXor, but this did not fix my problem. I was hoping that terminal program would help, but all the settings were fine. I just couldn't remember how to bring it up. Here is a screen shot of what I was seeing. I know nothing is muted.

enter image description here

Also, it is not the headphones that is the problem. Headphones are the ONLY thing that works. The speakers don't. And I am almost positive its not a broken speaker because it suddenly cut out while watching a WebM video. No popping or weird noise. Just all the sudden no sound while I was sitting not touching the computer at all. Also, when I'm looking at the PulseAudio controller. It shows that the sound is playing with the bar that moves as a song or a video plays. Speakers are selected, not muted, but no sound at all. :-(

Update #3 and Final Took the laptop to a repair shop, as many other things were going wrong, and turns out the hardware Wal-Mart sells is extremely low quaility motherboards and other parts, that have been marked up to standard quality prices. Capacitors that burn out very easy, and the like. The laptop is now waiting to be recycled. So seems like this was a hardware problem after all. Sorry to all that worked so hard to help. It just seemed like it had to be software related, as the 2 times it cut out, then came back, were at the exact same time stamp of a particular video file. Once on the HDD installed Ubuntu, then the second cut out was on a LiveUSB instance. Where the moment I booted into the LiveUSB sound worked fine, then cut out once the said video was played. But never came back. Since then I've using the HDD out of it as a portable LIVE Drive, that I can take anywhere with me to have full size storage to boot into from any computer. Nice backup system.

Thank you all for the hard thoughtful advice and help. And God Bless

share|improve this question
1  
If i understand correctly, you booted from a thumb drive and it still didn't work? If that is the case then its not the fault of the current installation, but a hardware failure. If you did not try a live cd/usb yet, try it and see what it does. –  Cheiron Aug 20 '13 at 19:56
    
No, Restarting into my normal Xubuntu install on the hard drive does not fix the problem. But using a Live USB does fix it sort of. But if while booted into that Live USB, I watch the same exact WebM video, the sound does the same thing about 5 to 10 minutes in. And nothing I do brings it back. No MP3's play, no OGG, no MP4 videos. Nothing. So this is not a hardware issue. Its complicated in the details, but I'm positive its a setting somewhere, but I have no idea how to find it. And Pulse Audio settings does not help. –  Daniel Clem Aug 25 '13 at 20:07
    
When you press the → key does it give you more options? –  RolandiXor Sep 9 '13 at 1:42
    
no it doesn't, I use Guake, which is why the terminal cover the whole top of the screen. Being not so tall, but so wide, makes the alsamixer squeeze into the small space, so it fits everything in the termianl easily. If I had a smaller terminal, it would do what your saying. But nope that is all the options alsamixer gives me. –  Daniel Clem Sep 10 '13 at 4:07

2 Answers 2

Run alsamixer in a terminal, and then ensure that PCM is not muted:

alsamixer

You may also need to check the volume of other settings depending on your sound card. To ensure you only do this for outputs, press F3, then raise the volume of each one using your arrow keys to select or raise the volume.

Your update gave me the answer.

Using alsamixer, look for the headphone jack sense option and ensure that it is unmuted. If muted, it will be marked "MM"

share|improve this answer
    
This is exactly the Terminal screen I was talking about. Thank you sir. Sadly it did not fix my problem though. :-( I just don't understand what could be causing it. –  Daniel Clem Sep 2 '13 at 21:11
    
From your update, I have spotted your problem. –  RolandiXor Sep 2 '13 at 21:42
    
Please read my newest update @RolandiXor. Sadly, the problem hasn't gone away. :-( –  Daniel Clem Sep 8 '13 at 16:11

First run:

sudo apt-get update
sudo apt-get upgrade alsa-base alsa-utils
sudo apt-get upgrade pulseaudio gstreamer0.10-pulseaudio

then run:

sudo alsa force-reload

And reboot if your sound still dosen't work try:

sudo gedit /etc/default/speech-dispatcher

Change RUN=yes to RUN=no and reboot.

share|improve this answer
    
I'm sorry, but no this did not fix the issue. It did have available updates for alsa. No updates for pulseaudio though. I think I primarily use Pulse since I use the program "Pulseaudio Volume Control" for all my settings. Like I said, it works fine with Headphones. But not at all with out headphones. But inside a Live USB or Live CD, the audio works fine. So this is not a hardware issue. Isn't there a way to change some deeper settings? –  Daniel Clem Sep 1 '13 at 17:02
    
if pulseaudio doesnt have any updates, try dpkg-reconfigure pulseaudio to reconfigure it. it may help –  mohammadh montazeri Sep 1 '13 at 19:24
    
@mohammadhmontazeri, that didn't change it either :-( I remember a long long time ago (about 2010 or so) when someone helped me fix a microphone problem with this same computer. And they had me go into the terminal and do some kind of command that brought up an interactive, almost atari like, settings menu inside the terminal itself. Had lots of colors and a black background (terminal normally had blue background). Where you changes lots of confusing and very technical settings. Does this sound familiar to anyone? I can't remember how to get to it. –  Daniel Clem Sep 1 '13 at 20:55
1  
it seems that you mean "alsamixer". type it in terminal and do the job.although all of them are available in "pavucontrol". install it by "sudo apt-get install pavucontrol" and do the job in graphical user interface.;) –  mohammadh montazeri Sep 5 '13 at 19:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.