Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My problem is when I configure a file in /etc, for instance, I made changes , with sudo,in

/etc/default/l2tp-ipsec-vpn-daemon

well, after restarting I noticed the changes I made are not applied and I found a new file

/etc/default/l2tp-ipsec-vpn-daemon~

beside my original file, and that file with the tilde at the end contains the initial configuration which is apparently applied instead of my changed file. This problem exists for every change I madke in /etc folder.

share|improve this question
    
How did you edit the file? What program did you use? –  guntbert Aug 20 '13 at 15:20
    
sudo gedit /path/to/file –  microarm15 Aug 20 '13 at 15:21
    
I still supect some kind of user error :-) (some programs create a ~ file as safeguard, to keep the last version). For a diagnosis: try it once more, then (before rebooting) look at the output of ls -l /etc/default/l2tp-ipsec-vpn-daemon (the date/time should be new) and cat /etc/default/l2tp-ipsec-vpn-daemon. –  guntbert Aug 20 '13 at 15:30

1 Answer 1

What your trying to change isn't actually the configuration. You're making edits to a pseudo file (a representation of the service). The service only outputs there.

To make changes to IPSEC edit this file:

sudo gedit /etc/ipsec.conf 

or this file for L2TP:

sudo gedit /etc/xl2tpd/xl2tpd.conf 

Use this site for config reference:

http://blog.riobard.com/2010/04/30/l2tp-over-ipsec-ubuntu/

share|improve this answer
    
thank you, for the l2tp-ipsec-vpn-daemon file, I just want to disable the daemon at startup; another file for example /etc/default/cups I want to disable lp driver. –  microarm15 Aug 20 '13 at 15:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.