Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was following this answer to install Windows on top of my existing Linux installation.

However, while running the Windows 7 installer it complains that the partition I am installing on is not a 'System' partition.

I have two HDs, set up like so:

sda (1 Tb)
   - sda1 ntfs (500 Gb) <-- Windows 7 goes here
   - sda2 lvm (500 Gb)  <-- Storage
sdb (128 Gb)
   - sdb1 lvm           <-- Linux installation (also boot flag in GParted)

The Windows 7 installer marks sdb1 as the System partition.

What do I need to do to move the System partition to sda so that I can install Windows?

share|improve this question
1  
It doesn't look like you need to move anything. sda, or /dev/sda is the device itself, in other words, the HDD, and sda1, sda2, sda3, etc are its partitions. So, sda1 is, by definition, already on the sda. ...you should probably add the output of sudo fdisk -l to the question. –  mikewhatever Aug 20 '13 at 13:37
    
@mikewhatever The question is: How do I move the boot flag from sdb to sda. –  ehuang Aug 21 '13 at 0:47
    
I'd recommend deleting the sda1 partition, and let the Windows installer re-create ...whatever it needs. It usually creates two, a 100MB boot partition, and the system partition, and takes care of the boot flag as well. –  mikewhatever Aug 21 '13 at 4:21

2 Answers 2

The boot flag is the active partition. And Windows boots from, repairs, or installs the partition with the boot flag on the drive set to boot from in BIOS. YOu should change BIOS to boot from sda and put a boot flag on sda1. Every drive can have one and only one boot flag, but Windows installs boot files onto drive & partition with boot flag. We have seen users install to sdb, but because BIOS was set to sda, the 100MB boot partition went on sda. Window will install in one partition, but like to have the separate Boot partition, primarily so you can encrypt the main install. But Boot partition also has the repair console, so if installed in one partition be sure to make a repairCD or flash drive.

share|improve this answer
up vote 0 down vote accepted

The problem was solved by going into my BIOS and setting the boot order of the drives to boot from sda first.

The boot flag is easily set through GParted (and Linux apparently disregards the boot flag).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.