Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to permanently mount my windows home server folders. My account work properly on every windows machine and this is the first time i want to mount it on linux.

For every shared folder i make a rule in fstab:

//192.168.1.3/Downloads /home/janco/mnt/downloads  cifs username=Janco,password=--- 0 0
//192.168.1.3/Pictures /home/janco/mnt/afbeeldingen  cifs username=Janco,password=--- 0 0
//192.168.1.3/Films /home/janco/mnt/films cifs username=Janco,password=--- 0 0
//192.168.1.3/Music /home/janco/mnt/music cifs username=Janco,password=--- 0 0
//192.168.1.3/Serie's /home/janco/mnt/series cifs username=Janco,password=--- 0 0
//192.168.1.3/Videos /home/janco/mnt/videos cifs username=Janco,password=--- 0 0

The mount works, i can read my files. But when i try to create a direcotry or change a file, i get a permission error: acces denied.

I have change the permission of the " /mnt" folder (with chmod) but this doesn't help. I can create a folder in the mnt folder, but not in a shared folder.

What could be the problem?

Some information about the server: OS: Windows home server 2011 Static ip: 192.168.1.3 Server name: FILESERVER

share|improve this question
add comment

1 Answer 1

Try by setting the RW (read write) switch... Like this for example:

//192.168.1.3/Videos /home/janco/mnt/videos cifs username=Janco,password=---,rw 0 0

I presumed that your "---" is where you put your password.

or this:

//192.168.1.3/Videos /home/janco/mnt/videos cifs  username=Janco,password=password,iocharset=utf8,sec=ntlm  

or even this:

//192.168.1.3/Videos /home/janco/mnt/videos smbfs  username=guest,password=,uid=1000,iocharset=utf8,codepage=unicode,unicode  0  0
share|improve this answer
    
Tried this but no result, stil no permissions. The weird thing is when i do mkdir /hoem/janco/mnt/videos/test i have no permissions to create the directory. But when i do sudo mkdir /home/janco/mnt/videos/test it works. –  user185719 Aug 20 '13 at 14:26
    
Can you connect manually using this command: smbclient //server/share -U user%password –  Colyn1337 Aug 20 '13 at 14:28
    
Yes i can connect manually. I can also connect through files -> entire network -> connect to server. It workes fine but i want a permanently mount. –  user185719 Aug 20 '13 at 14:36
    
I updated my answer with an additional solution. Try that one and see if it works. –  Colyn1337 Aug 20 '13 at 14:39
    
Again not working :( I can still read my shared folders but i don't have any write permissions. I can only write if i'm super user (sudo). –  user185719 Aug 20 '13 at 14:50
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.