Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just have had nasty surprise of graphics not working after latest update (bringing it up to kernel version 3.2.0-52-generic). Apparently after the update it was expecting nvidia-319 driver, while it seems to me that on 12.04 nvidia-current points to nvidia-304. Thus I had to manually install nvidia-319 and uninstall nvidia-304.

Is this because I've have messed up something in my configuration or is it known issue?

share|improve this question
    
It happens when there are two different version of nvidia driver in the system. It is a known issue. You need to take care of the nvidia version of your kernel and the graphic card identical. –  NKN Aug 20 '13 at 13:46
    
@NKN: why doesn't kernel update have that as dependency then? Or why isn't nvidia-current updated when kernel is? –  vartec Aug 20 '13 at 13:53
    
I will switch to post an answer and I will update it. –  NKN Aug 20 '13 at 14:32
add comment

2 Answers 2

Check this question, and similar questions first. It happens when there are two different version of nvidia driver in the system. It is a known issue. You need to take care of the nvidia version of your kernel and the graphic card identical. Or, If you didn't uninstall your previous driver version. This can happen because nvidia-current-dev is of version 304 and nvidia-current-updates-dev is of version 319 as reported.

If you've installed the nVidia driver from Ubuntu's Additional Drivers dialogue , try

sudo apt-get purge nvidia* 

then try reinstalling by

sudo apt-get install nvidia-current-updates-dev 

then reboot. If you have used the .run file from nVidia's website then go to a console by pressing Alt+Ctrl+F1 and then run

nvidia-xxx-pkg1.run --uninstall 

to remove the previous driver components. Now give a reboot and see if that works. If not, then execute

sudo echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf

so that the default nouveau driver for nVidia chipsets are not loaded instead of proprietary one. Finally install packaged binary drivers by

sudo apt-get install nvidia-current-updates-dev

chekc this link as well.

share|improve this answer
    
on 12.04, nvidia-current = nvidia-current-updates = nvidia-304, all of which are at version 304.88.ubuntu0.0.3. –  vartec Aug 20 '13 at 14:25
    
If you still have the problem, just uninstall everything related to nvidia and install it properly again. mine is 304.88.ubuntu0.0.2. –  NKN Aug 20 '13 at 14:31
    
As I've wrote in the question, I have solved the problem manually. What I don't understand why would I have problem in the first place if I did proper update, which should have taken care of properly updating the packages. –  vartec Aug 20 '13 at 14:38
3  
I've had this similar issue, What I did was purge everything realted to nvidia. And did an apt-get update. Then went to Preferrences > Additional Drivers > then chose the nvidia recommended Propietary Drivers. NVIDIA accelerated graphic driver [Recommended], I've chosen that option and clicked activate. My Kernel version is 3.2.0-51-generic –  Gary Lising Aug 20 '13 at 15:33
    
sudo echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf doesn't work as sudo only elevates the echo command, not the pipe to blacklist.conf –  ACyclic Nov 24 '13 at 17:56
add comment

After you

sudo apt-get purge nvidia*

try:

sudo apt-get install nvidia-319-updates-dev

This worked for me, without the 319 it just re installed 304.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.