Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded metasploit 64 bit version for linux (I have ubuntu 13.04 x64 installed). It comes as a .run file. As all of the tutorials say, I tried to install it as follows.

sudo chmod a+x metasploit-latest-linux-x64-installer.run
./metasploit-latest-linux-x64-installer.run

But I encountered the following error. I have tried many times, but same result in each attempt. I get the error message followed by a % prompt as follows.

application-specific initialization failed: 
  /home/djays/metasploit-latest-linux-x64-installer.run has no VFS data to start up
% 

Then I tried to install it using bash command. It also gives another error.

metasploit-latest-linux-x64-installer.run: metasploit-latest-linux-x64-installer.run: cannot execute binary file

Can anybody give me a solution.

Edit: As some answers said in the internet, I checked whether downloaded .run file is corrupted or not downloaded completely, and then I redownloaded it about 4 times. But still get the same result. I checked whether gvfs is installed, and the latest version is installed in my machine.

share|improve this question
    
Can you try sudo ./metasploit-latest-linux-x64-installer.run? –  Alaa Aug 20 '13 at 6:34
2  
Check the size of the installer. This can happen if the download was not completed. –  Rinzwind Aug 20 '13 at 6:40
2  
It's probably a corrupted file. I just downloaded the 64-bit installer from here (scroll down and look for Metasploit Framework) and it works. It's around 170 MB and the md5 hash is b36d8c7282f91e8bcb0138f2feb702cf. Check yours and see if it matches (check the hash by md5sum metasploit-latest-linux-x64-installer.run). –  Alaa Aug 20 '13 at 6:59
1  
Well boys, save your goodies in an answer for the solved problem. –  Radu Rădeanu Aug 20 '13 at 7:12
1  
Yes, I downloaded both of them and they were both 167 MB. Don't forget to mark your answer as accepted when you can =). –  Alaa Aug 20 '13 at 9:29
show 7 more comments

1 Answer

up vote 2 down vote accepted

This is definitely due to the bad downloaded file. I downloaded 32bit version of Metasploit and installed. Though initial step worked, starting metasploit fails because of the conflicting of rubygems. So, I uninstalled the 32bit Metasploit and installed newly downloaded 64bit Metasploit. It worked perfectly and Metasploit can be run without no error. All problems solved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.