Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been trying to get Ubuntu 13.04 to work on my desktop that came with Windows 8 pre-installed and the UEFI system. Needless to say, I'm having trouble. The desktop in question is an HP Pavilion P6-2738. It also seems that I need to get drivers somehow for the ethernet adapter, but that's a whole different thread.

I went into the BIOS/UEFI editor and disabled secure boot, enabled legacy mode. During installation, Ubuntu says it can't install GRUB2, no matter where I tell it to install it. I'm using the "something else" option and defining my own partitions. I have a seperate 160GiB drive I'm using for it, so maybe that's the issue. I don't know. Any and all help is appreciated, as it's late, and I'm out of ideas.

I'm trying to get it to dual-boot btw. Probably worth mentioning :P

Update: At the end of the installation, it says it's completely removing, and occasionally purging stuff. I got it to install grub to a separate partition. I'm not worried about getting an OS selection screen yet, but just going directly into the boot selection screen and selecting my secondary drive to boot from, I get "OS failed to load".

share|improve this question

Your Windows system is installed in UEFI GPT partitions. All hard drive is formatted as GPT, so when you trying to boot as Legacy, you are not able to make dual boot.

Why don't you use UEFI-boot for installing Ubuntu? It supports EFI partitions as well. It differs a bit from Legacy mode booting, but still works good.

Check this out

Installing Ubuntu on a Pre-Installed Windows 8 (64-bit) System (UEFI Supported)

share|improve this answer
When I try installing it with UEFI enabled, I get the black/grey text screen for asking if I want to try or install it, and then whatever option I choose the screen just goes to black and nothing happens. – TechnicolorDalek Aug 20 '13 at 13:57
have you tried other Linux distros? – RIO Aug 20 '13 at 16:48

Your issue is a lack of BIOS-Boot partition.

Your disk is GPT type, and you disabled EFI, so you need to create such a BIOS-Boot partition during the disk partitioning. See this page for more info.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.