Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed netflix-desktop on my system running Ubuntu 12.04, and the app simply wouldn't launch. I removed it with these instructions here. I also ran these commands to clear out any settings: rm -Rf ~/.wine-browser and rm -Rf ~/.netflix-desktop.

I tried to reinstall with the instructions here, but I received the following error message:

sudo apt-get install netflix-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package netflix-desktop is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  wine-browser-installer

E: Package 'netflix-desktop' has no installation candidate

I also tried installing wine-browser-installer, and that didn't work. Any suggestions?

share|improve this question
    
I forgot to add: I'm running 12.04 LTS. –  user185616 Aug 20 '13 at 3:51
    
Did you completely follow the steps in the installation instructions? Does the command ls -l /etc/apt/sources.list.d/ehoover* output anything? This is just to make sure that the PPA was added successfully. –  Alaa Ali Aug 20 '13 at 5:22

2 Answers 2

Try: sudo apt-get purge netflix-desktop && sudo apt-get autoremove && sudo apt-add-repository ppa:ehoover/compholio && sudo apt-get update && sudo apt-get install netflix-desktop

This should (in theory) purge the entire netflix-desktop package and, since it sounds like you removed the ppa as well, add it back and reinstall the package. Omit sudo apt-add-repository ppa:ehoover/compholio && sudo apt-get update && if you did not remove the ppa.

Instructions as per http://ubuntuforums.org/archive/index.php/t-2084592-p-2.html and http://www.itworld.com/software/358908/install-netflix-ubuntu-1304

share|improve this answer

I had the same error. I removed netflix-desktop and purged the ppa. However, I also had to remove the following two files from /etc/apt/sources.list.d/ehoover-compholio-precise.list and /etc/apt/sources.list.d/ehoover-compholio-precise.list.save.

I had to remove these two files before I could correctly add the ppa and install netflix-desktop again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.