Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a lot of issues with Samba and trying to connect it up with a MyWorldBook NAS drive.

Running Maverick

  • I have the Samba 2:3.5.4 package installed that the distro came loaded with.
  • I can see the Windows Network and see MyBookWorld attached.
  • I click on it, it says it's opening, then hangs, and brings up "Cannot retrieve share list from server.
  • I've tried to browse on other computers, Mac and W7, and it works fine.

If anyone can lend a hand or some advice I would truly appreciate it. I had Samba working in Lucid and it would work, so I'm scratching my head on this one.

share|improve this question
    
Have you tried changing the workgroup in "/etc/smb.conf"? –  Alex Stevens Apr 15 '11 at 2:08

1 Answer 1

gksudo gedit /etc/samba/smb.conf

Check your workgroup

# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = WORKGROUP

Change if needed.

Keep me informed

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.