Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't do anything with apt-get because there are a stupid package that blocks it from working. This is what happens:

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 gimp-help-sv : Depends: gimp-help-common (= 1:2.8-0precise8~ppa) but 1:2.8-0precise16~ppa is installed
E: Unmet dependencies. Try using -f.

Ok, I guess I run apt-get -f install then.

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 27 not upgraded.
Need to get 0 B/29.6 MB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? 
(Reading database ... 803609 files and directories currently installed.)
Preparing to replace gimp-help-sv 1:2.8-0precise8~ppa (using .../gimp-help-sv_1%3a2.8-0precise16~ppa_all.deb) ...
Unpacking replacement gimp-help-sv ...
dpkg: error processing /var/cache/apt/archives/gimp-help-sv_1%3a2.8-0precise16~ppa_all.deb (--unpack):
 unable to create `/usr/share/gimp/2.0/help/sv/gimp-tool-crop.html.dpkg-new' (while processing `./usr/share/gimp/2.0/help/sv/gimp-tool-crop.html'): No space left on device
No apport report written because the error message indicates a disk full error
                                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ok. But it can't be that I've ran out of space?

$ df -H
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda2        15G   11G  3.1G  79% /
udev            2.1G  4.1k  2.1G   1% /dev
tmpfs           828M  1.1M  827M   1% /run
none            5.3M     0  5.3M   0% /run/lock
none            2.1G  316k  2.1G   1% /run/shm
/dev/sda5       125G  103G   16G  88% /home

This is what happens whatever I am trying to do. How can I get rid of those stupid messages?

share|improve this question

marked as duplicate by Seth, Eric Carvalho, Alvin Row, Kevin Bowen, Warren Hill Aug 20 '13 at 12:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

I think that sudo dpkg --purge --force-depends "gimp*" worked. Should the question be closed as duplicate it that's the case? – Niclas Nilsson Aug 19 '13 at 20:26
You should write this solution as an answer yourself, and then the question may or may not be closed as duplicate. – Richard Aug 19 '13 at 20:28
Ok, I did that. And I also flagged it as such myself. Thanks. – Niclas Nilsson Aug 19 '13 at 20:31
up vote 1 down vote accepted

All I had to do was to execute:

sudo dpkg --purge --force-depends "gimp*"

The solution was really in this earlier question.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.