Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am able to run Ubuntu from a live USB installer, but when I install it onto the hard drive of my pre-installed Windows 8 computer, on reboot, it does not load. I get as far as a menu asking me if I want Ubuntu, but when I click on it, the screen goes black with only a flickering cursor.

If I reboot and load Ubuntu off the USB installer again, it works, but never from the HDD installation.

Can someone please help me?


HP NE56R31u

Don't know about encrypted hard drive. I am not that technical-minded. But the computer came with Windows 8 pre-installed. I paid a tech to remove it and he installed Windows 7 instead. Now am trying to set up a dual boot with Windows 7 and Ubuntu.

I was able to boot into Ubuntu 13.04 from a live usb and do an installation. However, upon reboot, I would get a black screen with a blinking cursor. Tried several of the fixes recommended here but none of them worked, and one of them made me unable to get to Grub, which made me unable to boot into even Windows and I became afraid. I at least want to have one os working on my machine.

Since it's been a few days and I am still unable to get Ubuntu to work despite begging for answers, I did a re-install, but this time with 12.04 LTS.

Once again the installation completed fine, but upon reboot, nothing. The error message this time is

Kernel panic - not syncing. No init found. Try passing init=option to kernel.

So ... I booted in again using the live usb and ran a boot repair. You can find the results here.

http://paste.ubuntu.com/6131996/

There are two things that stood out for me during the boot repair:

cryptsetup: WARNING: failed to detect canonical device of overlayfs
cryptsetup: WARNING: could not determine root device from /etc/fstab

and

(glade2script:16608): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.MTNG3W': No such file or directory

(glade2script:16608): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

$ cat /etc/fstab
overlayfs / overlayfs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda5 swap swap defaults 0 0

Can someone please help me? It's been WEEKS!

share|improve this question
    
What's the make and model of the computer (if it's an HP, include the product number). Do you have an encrypted hard drive? –  Colyn1337 Aug 19 '13 at 14:04
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.