Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to use tab completion for commands in Ubuntu 11.04 Beta 1, running all the latest updates, but it doesn't seem to work. (Though package bash-completion is installed)

Tab completion works correctly only for directories or files.

Any ideas where to dig?

share|improve this question
    
I solved this problem using the solution given at askubuntu.com/questions/325807/… –  user719520 Dec 18 '13 at 22:24

4 Answers 4

up vote 19 down vote accepted

Check whether you have the following fragment in your .bashrc (should be there by default)

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi
share|improve this answer
    
Thanks! I have replaced .bashrc with my own and therefore could not figure out what the problem was in. Works perfectly now. –  Screatch Apr 4 '11 at 11:13
    
this fixed my git bash autocompletes at xubuntu 12.04 too, many thanks. –  palmic May 27 '12 at 22:40

I thought I would also add the following additional explanation for a failure of bash completion- it is too long for a comment and may be useful for someone who has a problem with bash completion, as presumably this is the 'general' canonical question to which all duplicates are referred.

Even if you have the appropriate line in your .bashrc (as in the answer above) and the bash-completion package installed, bash completion can still malfunction if you have either shopt -s nullglob or shopt -s failglob in your .bashrc or .bash_aliases.

The following scenarios were tested with all user customisations of .bashrc and .bash_aliases removed to give a fair test, with the appropriate bash completion line in .bashrc present and with bash-completion installed.

1) The first scenario is when you have shopt -s failglob in your .bashrc or .bash_aliases.

When trying to tab complete directories and files respectively, these errors will occur:

cd Dbash: no match: "${COMP_WORDS[@]}"  
cat pabash: no match: words[0]=${!ref}${COMP_WORDS[i]}

However, commands will still complete successfully.

2) With shopt -s nullglob enabled, trying to tab complete a directory or a file will instead lead to everything being listed, with no completion:

cd Do
.adobe/                  .gimp-2.6/               Podcasts/
.aptitude/               .gnome2/                 Public/
.audacity-data/          .gnome2_private/         .pulse/
............

I have cut short the listing here, as it was very long and not necessary to reproduce it all.

Again, command completion will still work however.

So, just removing shopt -s failglob or shopt -s nullglob could also solve the problem of errors with bash completion, assuming that you have the appropiate line in your .bashrc and bash-completion installed.

share|improve this answer

As basic as it may sound make sure that bash is your active shell

echo $SHELL

I just upgraded to Ubuntu 14.04.1 LTS and had no tab auto-completion, even after following the advice on this post, only to realize my shell was set to /bin/sh and not /bin/bash.

share|improve this answer

Updating to Ubuntu 14.04.01

Check whether you have the following fragment in your .bashrc (should be there by default)

sudo vim /etc/bash.bashrc (type "i" to edit the file)

    # enable bash completion in interactive shells
    if ! shopt -oq posix; then
     if [ -f /usr/share/bash-completion/bash_completion ]; then
        . /usr/share/bash-completion/bash_completion
      elif [ -f /etc/bash_completion ]; then
        . /etc/bash_completion
      fi
    fi

Uncomment 7 lines above

Save file "esc + w + q + enter"

Restart bash

exec bash

share|improve this answer
1  
What will this do? Isn't this like this by default? –  Tim Sep 2 at 20:55
    
Like @Tim says, that configuration is provided by default config. –  ssoto Nov 17 at 11:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.