Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been having problems with wireless on Ubuntu 10 and above, Mint 11 and above. The problem is in the driver for the wireless... I can see that there is no driver installed and yet it works but reduced a lot, for example:

on windows 7 ultimate 100% on distance of 1 meter

(currently running) Mint Cinnamon 15 on same distance 70% when it goes under the 40 % it simply disconnects and than takes a lot of time to connect again

I am new to Linux and I don't know anything about programming, yet I love the interface and look of the OS but don't want to reject it for couple of problems.

There is, however, a problem with brightness control on laptop, it shows the notification and slider but with no effect

The question is:

Can somebody explain to me where to download and how to install the ar9285 driver for atheros wireless card laptop acer emachines eme529?


can someone explain this to me only for the LINUX MINT 15 because the synaptic's interface is different than of mint 15

I KNOW this is Ubuntu community but the problems persist in all Linux versions

share|improve this question
As you say, this is an Ubuntu Q&A site, so why ask for answers to Mint? Surely you should be asking this on one of the Mint forums – SimplySimon Aug 18 '13 at 17:45
If you want a site more general than the Linux Mint forums, you might consider searching for and (if you don't find a solution) posting a question on Unix.SE. It would be on-topic there. – Eliah Kagan Aug 18 '13 at 18:03

The driver is already installed by default but it does not work great, but there is a tweak we can do to help.

echo "options ath9k nohwcrypt=1" | sudo tee  /etc/modprobe.d/ath9k.conf
sudo modprobe -rfv ath9k
sudo modprobe -v ath9k
share|improve this answer
This removes the driver! – Jonathan. Jan 5 at 5:34
This works for older versions of ubuntu not newer versions, that is why it did not work. This post is more then 2 and a half years old. – Wild Man Jan 5 at 20:31

I tried the following solution and it worked fine for me: sudo -i echo "options ath9k nohwcrypt=1 ps_enable=1" >> /etc/modprobe.d/ath9k.conf modprobe -r ath9k modprobe ath9k nohwcrypt=1 modprobe ath9k ps_enable=1

Then, reboot your system to take affect.
To get more option, see here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.