Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The problem

I have a rather old (~2007ish) iMac, which I've recently installed Xubuntu 13.04 (64 bit) on. For various reasons it's important that I'm able to get reasonable 2D graphics acceleration on this machine, and unfortunately mesa doesn't quite cut it. I've therefore been battling to install the proprietary AMD drivers, but with no success so far.

According to the output of lspci | grep VGA, I seem to have an AMD Mobility Radeon HD 2600 XT/2700. Looking in Settings Manager > Software & Updates >Additional drivers I don't see any option to install a proprietary display driver.

Things I've tried:

1) Installing fglrx or fglrx-updates from the normal Raring restricted repository

In both cases lightdm doesn't start at all. dmesg | tail gives me:

[   21.939526] AMD IOMMUv2 driver by Joerg Roedel <joerg.roedel@amd.com>
[   21.939530] AMD IOMMUv2 functionality not available on this system`
[   22.078527] <6>[fglrx] Maximum main memory to use for locked dma buffers: 1873 MBytes.
[   22.078991] <3>[fglrx:firegl_init_device_list] *ERROR* No supported display adapters were found
[   22.078993] <3>[fglrx:firegl_init_module] *ERROR* firegl_init_devices failed

Based on the AMD website and on various other answers on this site, it seems that the Radeon HD 2000 - 4000 series of adapters is no longer supported by the mainline Catalyst drivers available directly from AMD, or the fglrx packages available from the standard Ubuntu repositories.

2) Adding this repository, downgrading Xserver to 1.12.4 and installing fglrx-legacy

This time the lightdm process seems to start, but the display is totally glitched-out (weird moving colour gradients). I see this in dmesg | tail:

[   18.562524] fglrx_pci 0000:01:00.0: irq 48 for MSI/MSI-X
[   18.562950] <6>[fglrx] Firegl kernel thread PID: 1264
[   18.563022] <6>[fglrx] Firegl kernel thread PID: 1265
[   18.563091] <6>[fglrx] Firegl kernel thread PID: 1266
[   18.563203] <6>[fglrx] IRQ 48 Enabled
[   19.847271] <6>[fglrx] Gart USWC size:624 M.
[   19.847275] <6>[fglrx] Gart cacheable size:245 M.
[   19.847279] <6>[fglrx] Reserved FB block: Shared offset:0, size:1000000 
[   19.847281] <6>[fglrx] Reserved FB block: Unshared offset:fe0b000, size:1f5000

3) Installing the legacy Catalyst drivers downloaded directly from the AMD website

During the installation I get a message saying DKMS part of installation failed. Please refer to /usr/share/ati/fglrx-install.log for details. The install log says this:

cd /var/lib/dkms/fglrx/8.97.100.7/build; sh make.sh --nohints --uname_r=3.8.0-27-generic --norootcheck......(bad exit status: 1)
[Error] Kernel Module : Failed to build fglrx-8.97.100.7 with DKMS
[Error] Kernel Module : Removing fglrx-8.97.100.7 from DKMS

It's presumably failing to build because that driver only supports kernel versions up to 3.4, whereas mine is 3.8.0-27.

What next?

Is there any way I can get proprietary AMD drivers working on Ubuntu with a Radeon HD 2600 XT? I'm open to other options, such as downgrading my version of Ubuntu or switching to a different window manager. Could anyone suggest any combination of Ubuntu and Catalyst versions that are likely to be compatible?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

I think you want to downgrade to (x)buntu 12.04, the most recent release that still used xorg 1.12, which is compatible with Radeon's legacy driver. Here and there were posted instructions for tricking Catalyst into more recent releases, but I haven't heard a success story in a long time. (Disclosure: My own Radeon graphics haven't gone legacy. Personally I don't have this problem yet. I just have an interest.)

share|improve this answer
    
I was initially under the impression that Xorg > 1.12 was specifically a requirement of Unity (post-12.04) - in fact, that's partly why I went for Xubuntu rather than Ubuntu. The link you posted looks pretty much like what I tried in 2), so I'm not that hopeful. Do you happen to know if LXDE and KDE also require Xorg > 1.12? –  ali_m Aug 18 '13 at 22:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.