Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a weird issue with Unity, it just stopped showing applications in the unity dash search menu.
I can't launch application unless I run them from the terminal.

I have tried to force unity re-installation with no success, and I could not find any other information regarding to this issue. Prior to full re-installation (I prefer not to, since my disk is encrypted) I am seeking for help. (I am a developer and would love to help with more information as needed).

An image

An image to applications is shown like this, when looking at Ubuntu dash search feature.

share|improve this question
1  
I think you're talking about the Ubuntu dash search engine. You can upload a picture and leave only a link to it. –  Gediminas Jeremiah Gudelis Aug 18 '13 at 15:20
    
ok - Thanks, this is the link to the image link –  Moshe Beeri Aug 19 '13 at 7:46
    
Searching for applications missing in dash, I got to this post I re installed unity-lens-applications and unity-lens-files and log out, but nothing had changed, any idea?? –  Moshe Beeri Aug 19 '13 at 7:57
    
trying this as well mv ~/.local/share/zeitgeist ~/.local/share/zeitgeist.bak –  Moshe Beeri Aug 19 '13 at 8:20
    
That did not help either. is there a way to re-install the whole unity package? –  Moshe Beeri Aug 19 '13 at 8:30

3 Answers 3

Try to remove and re-install unity-lens-applications

sudo apt-get purge unity-lens-applications    
sudo apt-get install unity-lens-applications 

Edit: Log off & login. If doesn't work restart your system (see comments)

share|improve this answer
    
10x but it did not helped :-( Still can not see applications in dash! –  Moshe Beeri Aug 29 '13 at 14:35
    
Any other suggestions? –  Moshe Beeri Sep 2 '13 at 9:46
2  
@rpadovani Just to say! Your tip work for me. But you need to restart your system after apply. Thanks for save my day! ;) –  B4NZ41 Apr 12 at 13:27
    
I had this same problem. Your solution worked for me. Thanks!! –  Matt Caswell Oct 26 at 21:25

Delete the .cache directory from home folder, logout and login again. It worked for me.

share|improve this answer
    
Thanks, But I already reinstalled the system. –  Moshe Beeri Jan 20 at 7:51
1  
In case you encounter the same issue again this should help you. –  a4anurag Jan 21 at 7:16
    
This worked for me –  Luis Lobo Borobia Nov 18 at 22:19

I got the same issue, for me reapplying of filters (in top right corner of your screenshot) worked. I still sometimes come across of Unity not showing applications after reboot, so I have to manually reapply filter settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.