Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a new computer, hoping to dual boot Win 8 and Ubuntu 13.04. I have successfully installed both OS, but in Ubuntu I have no connection to the internet, even though the ethernet cable is plugged in and internet works perfectly in Win 8. Already in the Ubuntu installer, it says that I have no internet connection.

Things that might be of interest:

  • I have this motherboard: MSI Z87-G45 Gaming (http://www.msi.com/product/mb/Z87-G45-GAMING.html#specification)
  • Internet did not work in Win 8 until I installed the networking drivers that came with the motherboard (Killer Ethernet something)
  • I have tried different installation configurations, tried v. 13.04, 12.04 and 12.10, and tried installing on a separate hard drive. (the fact that the installer says "no internet connection" seems to indicate that the problem has nothing to do with the installation though.)
  • I can't even reach my router at 192.168.0.1.
  • The motherboard has no wireless capabilities.
  • If I run the terminal command lspci I get the following output (among other things):

03:00.0 Ethernet controller: Qualcomm Atheros Killer E2200 Gigabit Ethernet Controller (rev 13)

I have spent hours and hours googling, trying many different suggested methods and not quite finding someone who seems to be having the same problem.

share|improve this question
    
If I run the terminal command lspci I get the following output (among other things): 03:00.0 Ethernet controller: Qualcomm Atheros Killer E2200 Gigabit Ethernet Controller (rev 13) –  user185020 Aug 17 '13 at 22:00
    
check out my reply in ubuntuforums.org –  Bart.a Aug 17 '13 at 23:14
    
Thank you! It's late and I need to sleep but I will try that method first thing tomorrow. –  user185020 Aug 17 '13 at 23:24
    
Let me know how it turns out.. –  Bart.a Aug 17 '13 at 23:39
add comment

4 Answers 4

I got information from another source that kernel 3.10 had support for this networking card. So what I did was install the kernel using this guide

First thing first, you have to download ALL deb files which are appropriate for your system architecture (32bit or 64bit), then put them in same folder for easy process.

Note: This answer is an updated version of the original post:

You need this one for sure:

And then depending on your architecture grab the next 2:

64bit:

32bit:

Once downloaded, simply run the following command to install:

sudo dpkg -i linux*.deb

In case, you want to remove this version of Kernel, run this command:

 sudo apt-get purge linux-image-3.11*

Very simple and the connection started working right away after update and restart. I haven't experienced any problems with the new kernel yet so as long as I don't I will stick with this solution. It seems though as the thread you linked to me described the same problem and I'm sure that would've fixed the problem as well.

For those of you who might want to follow the instructions in that thread, on the top of page 7 there is a post from someone who had made a patch for this issue (not sure exactly how it worked but I guess it was to simplify and reduce the manual hacking as described in the first post).

An infinite thank you to all of those who helped me!

share|improve this answer
add comment

According to these posts from sauyon and Mahler122 on ubuntuforums.org you have to compile a kernel module for this network card manually.

Open a Terminal by pressing CTRL+ALT+T. First you need to install some packages that are needed for compiling. Type:

sudo apt-get update
sudo apt-get install fakeroot build-essential linux-headers-$(uname -r)

Create a new folder, download the Compat-Wireless sources and extract them:

mkdir compat_src
cd !$
wget http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.9-rc2/compat-drivers-3.9-rc2-2-su.tar.bz2
tar xvjf !$:t
cd compat-drivers-3.9-rc2-2-su

Download sauyon's patch and test if it works (I posted it on gist.github.com because the original source is behind ubuntuforum.org's login page. Hope this is ok):

wget https://gist.github.com/Germar/ea11bc1e998fee965f03/raw/5b1d28d42f0d4f2c4bf063002fde126becc61928/alx-patch.txt
patch --dry-run -p1 < alx-patch.txt

If there was no error, apply the patch:

patch -p1 < alx-patch.txt

Than select the driver that should be build, build and install it:

./scripts/driver-select alx
fakeroot make
sudo make install
sudo modprobe alx

EDIT: How to do that without working internet:

I just remembered that you have no internet so you can't use apt-get or wget :D. So you need to download everything on an other computer with internet access (or in your Win8 installation) and transfer it with e.g. an USB-Thumbdrive.

In Ubuntu open a Terminal and type:

sudo apt-get -qq --print-uris install fakeroot build-essential linux-headers-$(uname -r) | cut -d\' -f 2 > urls.txt

Copy the urls.txt to your thumbdrive and move over to the other computer. Download all files in urls.txt (if the other computer is running Linux you can use wget < urls.txt) and save them in a folder called deb on your thumbdrive. Also download compat-drivers-3.9-rc2-2-su.tar.bz2 and alx-patch.txt

Next move back to your faulty Ubuntu, plug in the thumbdrive, open a Terminal and type:

cd /media/YOUR_USERNAME/THUMBDRIVE_NAME
sudo cp deb/* /var/cache/apt/archives/
sudo apt-get install fakeroot build-essential linux-headers-$(uname -r)
mkdir -p ~/compat_src/compat-drivers-3.9-rc2-2-su
cp compat-drivers-3.9-rc2-2-su.tar.bz2 ~/compat_src/
cp alx-patch.txt ~/compat_src/compat-drivers-3.9-rc2-2-su/
cd ~/compat_src
tar xvjf compat-drivers-3.9-rc2-2-su.tar.bz2
cd compat-drivers-3.9-rc2-2-su
patch --dry-run -p1 < alx-patch.txt
patch -p1 < alx-patch.txt
./scripts/driver-select alx
fakeroot make
sudo make install
sudo modprobe alx
share|improve this answer
add comment

You could purchase a Realtek Edimax USB WiFi adapter to connect. These can be found here.

share|improve this answer
    
Thanks, that is a good alternative. But if possible I would really like to get the ethernet connection working. –  user185020 Aug 17 '13 at 22:19
    
Please see this. No patch is required. ubuntuforums.org/showthread.php?t=2166562&highlight=E2200 –  chili555 Aug 18 '13 at 23:47
add comment

I just worked through this and the best solution was found from ubuntuforums

The patch mentioned in the first technique has been merged into the kernel. This means that rather than patch you can load this backport file from kernal.org, and then simply run:

  cd Desktop/backports-3.10-2
  make defconfig-alx
  make
  sudo make install
  sudo modprobe alx

It is much simpler than patching.

The first post having problems, that it doesn't detect my Nvidia driver

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.