Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to use my camera's microfone to chat within skype.

In my systemwide sound options, I have two entries in the Equipment tab: One Duplex for the Internal SoundCard and one input for the camera. Though, I am unable to get the camera's entry listed on the "Input" tab. Does anyone know how should I proceed in order to use my camera's microphone?

Thanks, Pedro

share|improve this question

5 Answers 5

First check the input tab, if your webcam mic is there, select the radio button beside it. If it isn't listed. Go into the hardware tab. Select the webcam input and change the Profile below. Then go into the input tab and select the radio button.

If it is selected in the input tab, it should work in Skype.

share|improve this answer
up vote 2 down vote accepted

My problem was that the webcam wasn't listed in the input tab. I was able to fix this by pluging the camera in and rebooting with it connected to the computer.

share|improve this answer

The problem is with Skype - for some reason the microphone stops working. Even though the mic was working alright with other software, it wasn't with Skype. I just entered:

sudo apt-get install skype

and things got back to normal.

share|improve this answer

It is not needed to install alsamixer. The problem is, that Skype doesn't know where to listen and there is no option how to say in Skype environment directly. Install PulseAudio Volume Control from Ubuntu Software Center or via Synaptic.

Start Skype and choose Options from blue S down. Select Sound Services. Check if both three options (Microphone, Speakers, Ringing) has setted PulseAudio Server (local). Uncheck Allow Skype to automatically... to prevent too silent sound.

Click button Open PulseAudio Volume Control, it should be visible down (if not, open it clasically from menu).

Skype Sound Services

In opened PulseAudio Volume Control application click tab Input devices and check, if microphone is functioning (it is visible on the horizontal scale).

Than click tab Recording. The page should be empty (no another device is recording). In Skype call Echo/Sound test service, or call somebody, who is able to endure on line. This is only that way, how to set up microphone! During the session in Volume Control is visible what is recording. Push button in upper right corner and choose your web camera microphone input from list.

enter image description here

In next session Skype should remember those settings, so it is not needed to do this setting always. I suppose, that it is stored in ~/.Skype directory for further session. Tested on Ubuntu x86-64 13.10, 14.04, Skype 4.2.0.11.

share|improve this answer

I solve that issue on my natty *installing alsamixer packages and deleted full Pulseaudio package. Of course, the Banshee connection on the top bar will disappear, but for me was the only way to solve it. Now, i use alsamixer controllers on the left unity bar to control volume. Don't forget to change de soundboard on skype options (choose this option if this is your case: "HDA ATI SB ALC888 Analog Default Audio Device")

and in the terminal (CTRL+ALT+T) type: alsamixer

then you'll have the power to control all of the sound of your machine and perhaps you should take care about disable "mic boost" and enable "Capture".

I hope i helped you.

Jorge

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.