Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Linux, and I keep encountering problems when I try to install or remove software. Does anyone happen to know what the problem is?

The errors read:

installArchives() failed: (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 348502 files and directories currently installed.)
Removing libreoffice-base ...
Processing triggers for man-db ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for mime-support ...
Setting up linux-image-3.8.0-25-generic (3.8.0-25.37) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-3.8.0-26-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.0-25-generic /boot/vmlinuz-3.8.0-25-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.8.0-25-generic /boot/vmlinuz-3.8.0-25-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.0-25-generic /boot/vmlinuz-3.8.0-25-generic
update-initramfs: Generating /boot/initrd.img-3.8.0-25-generic

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.8.0-25-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.8.0-25-generic.postinst line 1010.
dpkg: error processing linux-image-3.8.0-25-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
No apport report written because MaxReports is reached already
Setting up linux-image-3.8.0-26-generic (3.8.0-26.38) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-3.8.0-25-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.0-26-generic /boot/vmlinuz-3.8.0-26-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.8.0-26-generic /boot/vmlinuz-3.8.0-26-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.0-26-generic /boot/vmlinuz-3.8.0-26-generic
update-initramfs: Generating /boot/initrd.img-3.8.0-26-generic

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.8.0-26-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.8.0-26-generic.postinst line 1010.
dpkg: error processing linux-image-3.8.0-26-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
No apport report written because MaxReports is reached already
Setting up linux-image-3.8.0-27-generic (3.8.0-27.40) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-3.8.0-26-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.0-27-generic /boot/vmlinuz-3.8.0-27-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.8.0-27-generic /boot/vmlinuz-3.8.0-27-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.0-27-generic /boot/vmlinuz-3.8.0-27-generic
update-initramfs: Generating /boot/initrd.img-3.8.0-27-generic

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.8.0-27-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.8.0-27-generic.postinst line 1010.
dpkg: error processing linux-image-3.8.0-27-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-extra-3.8.0-27-generic:
 linux-image-extra-3.8.0-27-generic depends on linux-image-3.8.0-27-generic; however:
  Package linux-image-3.8.0-27-generic is not configured yet.

dpkg: error processing linux-image-extra-3.8.0-27-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-3.8.0-27-generic; however:
  Package linux-image-3.8.0-27-generic is not configured yet.
 linux-image-generic depends on linux-image-extra-3.8.0-27-generic; however:
  Package linux-image-extra-3.8.0-27-generic is not configured yet.

dpkg: error processing linux-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-geNo apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
neric:
 linux-generic depends on linux-image-generic (= 3.8.0.27.45); however:
  Package linux-image-generic is not configured yet.

dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic-pae:
 linux-generic-pae depends on linux-generic (= 3.8.0.27.45); however:
  Package linux-generic is not configured yet.

dpkg: error processing linux-generic-pae (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-extra-3.8.0-25-generic:
 linux-image-extra-3.8.0-25-generic depends on linux-image-3.8.0-25-generic; however:
  Package linux-image-3.8.0-25-generic is not configured yet.

dpkg: error processing linux-image-extra-3.8.0-25-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-extra-3.8.0-26-generic:
 linux-image-extra-3.8.0-26-generic depends on linux-image-3.8.0-26-generic; however:
  Package linux-image-3.8.0-26-generic is not configured yet.

dpkg: error processing linux-image-extra-3.8.0-26-generic (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-3.8.0-25-generic
 linux-image-3.8.0-26-generic
 linux-image-3.8.0-27-generic
 linux-image-extra-3.8.0-27-generic
Setting up linux-image-3.8.0-27-generic (3.8.0-27.40) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-3.8.0-27-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.0-27-generic /boot/vmlinuz-3.8.0-27-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.8.0-27-generic /boot/vmlinuz-3.8.0-27-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.0-27-generic /boot/vmlinuz-3.8.0-27-generic
update-initramfs: Generating /boot/initrd.img-3.8.0-27-generic

gzip: stdout: No space left on device
cpio: write error: Broken pipe
E: mkinitramfs failure cpio 1 gzip 1
update-initramfs: failed for /boot/initrd.img-3.8.0-27-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.8.0-27-generic.postinst line 1010.
dpkg: error processing linux-image-3.8.0-27-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up linux-image-3.8.0-25-generic (3.8.0-25.37) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-3.8.0-27-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.0-25-generic /boot/vmlinuz-3.8.0-25-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.8.0-25-generic /boot/vmlinuz-3.8.0-25-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.0-25-generic /boot/vmlinuz-3.8.0-25-generic
update-initramfs: Generating /boot/initrd.img-3.8.0-25-generic

gzip: stdout: No space left on device
cpio: write error: Broken pipe
E: mkinitramfs failure cpio 1 gzip 1
update-initramfs: failed for /boot/initrd.img-3.8.0-25-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.8.0-25-generic.postinst line 1010.
dpkg: error processing linux-image-3.8.0-25-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-3.8.0-27-generic; however:
  Package linux-image-3.8.0-27-generic is not configured yet.

dpkg: error processing linux-image-generic (--configure):
 dependency problems - leaving unconfigured
Setting up linux-image-3.8.0-26-generic (3.8.0-26.38) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-3.8.0-25-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.0-26-generic /boot/vmlinuz-3.8.0-26-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.8.0-26-generic /boot/vmlinuz-3.8.0-26-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.0-26-generic /boot/vmlinuz-3.8.0-26-generic
update-initramfs: Generating /boot/initrd.img-3.8.0-26-generic

gzip: stdout: No space left on device
cpio: write error: Broken pipe
E: mkinitramfs failure cpio 1 gzip 1
update-initramfs: failed for /boot/initrd.img-3.8.0-26-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.8.0-26-generic.postinst line 1010.
dpkg: error processing linux-image-3.8.0-26-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-extra-3.8.0-27-generic:
 linux-image-extra-3.8.0-27-generic depends on linux-image-3.8.0-27-generic; however:
  Package linux-image-3.8.0-27-generic is not configured yet.

dpkg: error processing linux-image-extra-3.8.0-27-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-extra-3.8.0-26-generic:
 linux-image-extra-3.8.0-26-generic depends on linux-image-3.8.0-26-generic; however:
  Package linux-image-3.8.0-26-generic is not configured yet.

dpkg: error processing linux-image-extra-3.8.0-26-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-extra-3.8.0-25-generic:
 linux-image-extra-3.8.0-25-generic depends on linux-image-3.8.0-25-generic; however:
  Package linux-image-3.8.0-25-generic is not configured yet.

dpkg: error processing linux-image-extra-3.8.0-25-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 3.8.0.27.45); however:
  Package linux-image-generic is not configured yet.

dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic-pae:
 linux-generic-pae depends on linux-generic (= 3.8.0.27.45); however:
  Package linux-generic is not configured yet.

dpkg: error processing linux-generic-pae (--configure):
 dependency problems - leaving unconfigured

Thank you!

share|improve this question
add comment

2 Answers

You have no more space available in your disk. Try to free space.

sudo apt-get autoclean && sudo apt-get autoremove

delete some unused software:

sudo apt-get remove package_name

Check for old big files that you don't use anymore in your /home:

find ~ -type f -size +10000k -exec ls -lh {} \; | awk '{ print $8 ": " $5 }'

After you have enough free space, try upgrading again.

share|improve this answer
add comment

If you're not comfortable with the terminal you can also try using Ubuntu Tweak for cleaning your disk, download it from here:

https://launchpad.net/ubuntu-tweak

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.