Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Upgraded my notebook to Natty Beta 1 two days ago. All seems to be in order except for a very annoying little thing. I used to have Google Chrome as my default browser, and after the upgrade, this default was changed to Firefox. Note that when I go to the Google Chrome settings and to the Firefox setting it seems that Google Chrome is set as my default browser, but whenever I click on a URL from outside a browser it's Firefox that comes up and not Chrome.

Any help will be much appreciated.

Thanks.

share|improve this question
add comment

3 Answers 3

up vote 6 down vote accepted

Turns out that there is this little application called "Preferred Applications" and you can set your default browser there. I figured this out, 2 minutes after posting my question. Well, three things are a mystery to me:

  1. Why was my default changed?
  2. How is a "new" user supposed to know about this "Preferred Applications" utility? This utility is not in the launcher, and I only recalled it by sheer luck.
  3. Why are the settings within Firefox and within Google Chrome not working?
share|improve this answer
3  
You're probably experiencing this bug report (upgrades usually don't mess with your preferred apps): bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/670128 –  Jorge Castro Apr 4 '11 at 0:18
    
Power button > system settings opens up the control panel where the preferred application manager, and the other tools previously found in the "system" menu, are now located - that's how a "new" user is suppose to find it –  Yi Jiang May 6 '11 at 8:30
    
If you have a new question please do not ask it in the body of an answer but either update your original question - or if the scope of your questions has changed from the original topic Ask a new Question –  Marco Ceppi May 6 '11 at 8:33
add comment

You should file a bug report for this, because this may be a bug that is part of 11.04. Again, 11.04 is in beta, so bugs are bound to happen.

share|improve this answer
    
EvilPhoenix, thanks! But I may simply just be an idiot... Turns out that there is this little application in Ubuntu called "Preferred Applications" and you can set your default browser there. I figured this out, 2 mins after posting my question. Well, three things are a mystery to me: 1. Why was my default changed? 2. How is a "new" user supposed to know about this "Preferred Applications" utility? 3. Why are the settings within Firefox and within Google Chrome not working? –  S B Apr 3 '11 at 23:15
1  
Again, Natty is in beta. The malfunctions like this are called bugs. The settings within Firefox and Chrome may not be applying, possibly due to a bug in Natty. As such, you may consider filing a bug report anyways. And Firefox and Chrome are supposed to apply settings anyways, so the lack of that working definitely points to some type of bug. –  Thomas W. Apr 4 '11 at 0:29
add comment

There should be an option in chrome such to check to see if it is the default browser it is easy to change from there.

Edited The button to set chrome as the system default browser is in the preferences menu or chrome.

share|improve this answer
    
There is a bug/feature in Ubuntu 11.04 that prevents/overrides that button from doing anything at all. The way to solve this problem is to go to the "Preferred Applications" and select chrome from there. –  Ole Christian May 6 '11 at 17:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.