Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
tony@tony-lap:~$ lspci -vvnn | grep 14e4 
08:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5753M Gigabit Ethernet PCI Express [14e4:16fd] (rev 21) 
10:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01) 

here is what I did to install bcm4311

//remove the old driver

sudo apt-get remove bcmwl-kernel-source

//To Install b43 driver

sudo apt-get install b43-fwcutter firmware-b43-installer
sudo gedit /etc/modules

add "b43" without quotes at the end of the textfile, note you can only use one module per line.

sudo gedit /etc/modprobe.d/blacklist.conf

add "blacklist wl" without quotes to keep the wrong module from being loaded on boot.

sudo reboot

click on system setting → click on “Additional Drivers” → select Broadcom std driver –> click on Activate I am getting an error after clicking activate on Additional Drivers, Please help!!!!!!!!


here is the output.

tony@tony-lap:~$ rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

tony@tony-lap:~$ dmesg|grep b43
[   19.802871] b43-phy0: Broadcom 4311 WLAN found (core revision 10)
[   20.947260] Registered led device: b43-phy0::tx
[   20.947291] Registered led device: b43-phy0::rx
[   20.947320] Registered led device: b43-phy0::radio
[   21.124062] b43-phy0: Loading firmware version 508.1084 (2009-01-14 01:32:01)
[   21.204649] b43-phy0: Radio hardware status changed to DISABLED
[   21.212038] b43-phy0: Radio turned on by software
[   21.212042] b43-phy0: The hardware RF-kill button still turns the radio physically 
off. Press the button to turn it on.

tony@tony-lap:~$ iwconfig
wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
lo        no wireless extensions.
eth0      no wireless extensions.
share|improve this question
    
I ran the 2 commands below, reboot my labtop. sudo apt-get remove --purge bcmwl-kernel-source sudo apt-get install linux-firmware-nonfree I do not see my wireless light on when I unconnected network wired –  user184665 Aug 16 '13 at 16:38
    
after rebooting, I saw wireless in the network screen of "system settings". but I am unable to turn it on. please help!!!!!! –  user184665 Aug 16 '13 at 17:49

2 Answers 2

The installation of the Broadcom STA driver by 'Additional Drivers' is incorrect for this device 14e4:4311. It adds a number of blacklists of needed drivers. It is not enough to remove the driver. In order to remove the blacklists, it must be purged:

sudo apt-get remove --purge bcmwl-kernel-source
sudo apt-get install linux-firmware-nonfree

Reboot and you wireless should be working correctly. Please stay away from 'Additional Drivers.'

share|improve this answer
    
I ran the 2 commands above, reboot my labtop. I do not see my wireless light on when I unconnected network wired. –  user184665 Aug 16 '13 at 16:32
    
What do these diagnostics tell us? rfkill list all; dmesg | grep b43; iwconfig –  chili555 Aug 16 '13 at 17:44
    
see the output above. –  user184665 Aug 19 '13 at 17:42
2  
There is the answer: "The hardware RF-kill button still turns the radio physically off. Press the button to turn it on." Please do so. –  chili555 Aug 19 '13 at 18:40

Basically your hardware is off. Try the physical switch on your laptop. Also try

rfkill unblock all command. The button may be "fn+f12" or some physical key on your laptop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.