Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have read and to some extent understood the issues surrounding UEFI and Ubuntu. However, I am not able to install Ubuntu 13.04 64-bit in UEFI mode next to an existing Windows 8 UEFI install.

In short what I do is:

  • I burned the Ubuntu iso to a DVD as well as a USB stick.
  • Then I keep UEFI boot activated, and secure boot DEactivated.

The UEFI Ubuntu menu comes up as it should, I can choose between "Try Ubuntu", "Install Ubuntu" etc. however, no matter which option I choose try or install, the screen goes blank and nothing more happens.

The same happens if I turn on secure boot and if I use the DVD or the USB stick. If I switch off UEFI and go to legacy mode, everything works fine and I did install Ubuntu that way. However, now if I want to use Windows 8 I have to go to BIOS every time and switch back to UEFI mode.

Any suggestions?

share|improve this question
1  
    
Thanks for your links, there are only two new suggestions I see there: try to set SATA to AHCI mode and try to post install efi-grub. Both do not seem promising to me but I will read further through the posts and see if some of it works - thanks! –  balint Aug 17 '13 at 15:58

1 Answer 1

  1. Make a clean usb with Ubuntu 12.04/ 13.04 (not a multiboot one!)
  2. Install Ubuntu as usually.
  3. Make bootable usb with supergrub or burn it on cd.
  4. Start Ubuntu with supergrub (Boot => Detect Any Os => Select your Ubuntu boot option).
  5. Once you have Ubuntu running install Synaptic package manager from the software center.
  6. Open Synaptic and search grub from the installed packages.
  7. Mark for reinstallation all packages that contain grub or grub2 (I don't remember which package was exactly, so I mark most of them).
  8. Reboot and grub should load.
  9. If Windows 8 still loading, enter in your UEFI BIOS boot options and select Ubuntu boot option.

It works fine for me.

PS: Don't try boot Windows 8 from the grub menu, it won't boot. If you want to boot Winows 8 just open your BIOS boot menu (Example: For ASUS motherboards boot menu press ESC) and select Windows 8.

share|improve this answer
    
thanks but as noted above I can install Ubutu without problems in "legacy" mode. As far as I understand thats what you are suggesting. What I wanted is to have both, Ubuntu and Windows8 installed side to side in UEFI mode, then it also should be no problem to have them in the same efi-grub boot menu. –  balint Aug 17 '13 at 16:02
    
Try to start ubuntu with supergrub usb/cd and reinstall grub packages. That was the only way I found to start ubuntu on my laptop. The only problem is that I have to select from boot options if I want to start windows 8, but I think that's not so important. –  Deus Aug 17 '13 at 23:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.