Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am sharing an internet connection with my friend using a D-link DSl-2750U wireless router and my network cars is Atheros AR9285. Recently I am unable to connect to the network sometimes.
What could be the problem?
iwconfig gave the following output:

   iwconfig
mon0      IEEE 802.11bgn  Mode:Monitor  Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"DLink"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

ifconfig gave the following output:

ifconfig
eth0      Link encap:Ethernet  HWaddr 78:84:3c:e7:0f:5a  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2458 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2458 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:172791 (172.7 KB)  TX bytes:172791 (172.7 KB)

mon0      Link encap:UNSPEC  HWaddr CC-AF-78-B3-E5-0F-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST NOTRAILERS RUNNING PROMISC ALLMULTI  MTU:1500  Metric:1
          RX packets:38404 errors:0 dropped:442 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2671272 (2.6 MB)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr cc:af:78:b3:e5:0f  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:89 errors:0 dropped:0 overruns:0 frame:0
          TX packets:185 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:22749 (22.7 KB)  TX bytes:32983 (32.9 KB)

nm-tool gave the following output: n

m-tool

NetworkManager Tool

State: connecting

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        78:84:3C:E7:0F:5A

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan0  [DLink] -------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             connecting (configuring)
  Default:           no
  HW Address:        CC:AF:78:B3:E5:0F

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 
    Chandu:          Infra, AC:F1:DF:E8:31:09, Freq 2412 MHz, Rate 54 Mb/s, Strength 32 WPA WPA2
    DLink:           Infra, FC:75:16:D4:60:32, Freq 2412 MHz, Rate 54 Mb/s, Strength 15
share|improve this question
2  
You need to mention what wireless router you are using, what network card you are using to connect to, Ubuntu version and anything else that helps. –  Luis Aug 18 '13 at 12:38
    
When you are unable to connect, can you get this information: iwconfig, ifconfig, nm-tool and /var/log/daemon.log. –  Braiam Aug 18 '13 at 14:46
    
I could'nt find /var/log/daemon.log –  M.Tarun Aug 21 '13 at 11:53
    
Is there a reason why you have a monitor interface mon0 enabled for your wireless card? –  Alaa Ali Aug 22 '13 at 8:24
    
I just used turned it on. Is there any problem with it –  M.Tarun Aug 22 '13 at 11:18

1 Answer 1

up vote 0 down vote accepted

I would not use monitor mode either, without more information these are the things that I see that may help. Please run:

echo "options ath9k nohwcrypt=1" | sudo tee  /etc/modprobe.d/ath9k.conf

sudo modprobe -rfv ath9k

sudo modprobe -v ath9k

If you insist on using monitor mode please try:

echo -e '#!/bin/bash\n/sbin/iwconfig mon0 power off' | sudo tee -a /etc/pm/power.d/wireless

that will turn power management off for mon0.

It is best to set your router to just wpa2 encryption if you have that option.

The signal strength is to low on both networks that you have listed to be able to connect too, but the first set of commands I gave you to run usually helps with that to some extent. You may need to move closer to your router to be able to connect especially if there are walls or something blocking the signal.

Your device is ar9285 with linux drivers it has the worst signal strength of all the devices in this series from my experience so you will not be able to get very far from your router no matter what you do.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.