Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This issue is about INTERNAL hard drives. NOT USB drives.

During my time using Ubuntu I have noticed that after updates, or sometimes vicariously at the whim of my system, my hard drives seem to change where they decide to mount in semi-random fashion. This is wrecking havoc with my symlinks and is quite frankly getting very tiresome. As I understand it 13.04 SHOULD mount my internal HDD at /media/[drive] and my removable drives at /media/[username]/[drive].

Well NOW suddenly my system has decided to mount ALL my drives at /media/[username]/[drive]. I used to be able to open the file manager and unmount them and when I remounted them they would 'fix' themselves and remount at /media/[drive]. I can no longer do that for some unknown reason. My internal drives now INSIST on being mounted at /media/[username]/[drive].

I have looked at my /ect/fstab and at the information in 'Disks' (see Is there a program to mount all of my drives automatically?) and none of it matches. Also in 'Disks' my drives are set to mount automatically but they don't. I always have to manually mount them.

To fix that I found https://help.ubuntu.com/community/AutomaticallyMountPartitions. Plus 'Disks' says that my disks are mounting at /mnt/[UUID] which they are not doing.

I am now thoroughly confused.

Do I use Disks OR fstab? Do I put the automount in Disks or in the startup applications. How do I get them to mount by UUID in the CORRECT location. There are TOO many methods and none match and NONE seem to talk to one another. Is there a definitive way, preferably with a GUI as I am not a CLI comfortable type, that I can use to fix this mess and get all my drives to automount on startup AND mount in the correct place CONSISTENTLY? This is driving me nuts!

Here is the info as per my system:

fstab:

proc            /proc           proc    nodev,noexec,nosuid 0       0

UUID=68bff081-9b80-4d38-8383-8dcf9f77850c /               ext4    errors=remount-ro 0       1

UUID=ada89abc-d3d6-4f5c-a4ed-176295a20842 none            swap    sw              0       0

/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Now most of this is gibberish to me.  I can pull out of this is that it is my root drive, the swap partition and a floppy drive.  I have NO issues with this one.  But my other 3 drives are NOT here!

Disks:

/dev/sda

Mount Point: /mnt/BE44C6F844C6B307

Identify As: /dev/disk/by-uuid/BE44C6F844C6B307

nosuid,nodev,nofail,x-gvfs-show

Mount on Startup checked YES (which it does NOT do)

Automatic Mount Options set to ON. (which it does NOT do)


/dev/sdb

Mount Point: /

Identify As: UUID=c642a00c-410d-4463-9da4-7c002541b81a

errors=remount-ro

Mount on Startup checked YES (which it DOES do)

Automatic Mount Options set to OFF. (But it DOES mount at startup automatically)

This is my root filesystem and matches my fstab so I guess that's why it automounts at startup.


/dev/sdc

Mount Point: /mnt/c642a00c-410d-4463-9da4-7c002541b81a

Identify As: /dev/disk/by-uuid/c642a00c-410d-4463-9da4-7c002541b81a

nosuid,nodev,nofail,x-gvfs-show

Mount on Startup checked YES (which it does NOT do)

Automatic Mount Options set to ON. (which it does NOT do)

/dev/sdd

Mount Point: /mnt/68787D0E787CDC6E

Identify As: /dev/disk/by-uuid/68787D0E787CDC6E

nosuid,nodev,nofail,x-gvfs-show

Mount on Startup checked YES (which it does NOT do)

Automatic Mount Options set to ON. (which it does NOT do)

I also added these drives to 'Startup Applications' each with the following commands as per https://help.ubuntu.com/community/AutomaticallyMountPartitions:

/usr/bin/udisks --mount /dev/disk/by-uuid/BE44C6F844C6B307

/usr/bin/udisks --mount /dev/disk/by-uuid/68787D0E787CDC6E

/usr/bin/udisks --mount /dev/disk/by-uuid/c642a00c-410d-4463-9da4-7c002541b81a

Devices sda, sdc, sdd are all listed as mounting at /mnt/[drive-uuid] (system wide) but are actually mounting at /media/[username]/[drive] (removable media) instead of /media/[drive] (per-user). So which of these three SHOULD they mount at and how do I get them to ACTUALLY do it? System wide is fine but I would have to change 200 or so symlinks. Is there a way to do that in bulk?

Please help, thanks.

share|improve this question
    
Of the drives I added to 'Startup Applications' it seems that only ONE of them will load on startup. I loads at /media/[disk]. I have to manually load the other two. They mount at /media/[username]/[drive]. –  Exomancer Aug 19 '13 at 3:44
add comment

2 Answers

I found MountManager and that seems to help. For some reason My USB drive INSISTS on mounting in the /media directory. I give up. I've no hair left to pull out so it can mount in Atlantis if it wants to. Also of note MountManager sometimes gives dual mounting locations but only uses one and Nautilus insists on seeing both. So beware if anyone else has a similar problem. No one has answered this so I guess it's closed although only partially solved.

share|improve this answer
add comment

If I cached this question earlier I would have given you an answer...

First of all, you only need to use the command blkid for identifying each partition, I see that in your post you have Identify As: entries, well blkid is about the same:

blkid
/dev/sda1: UUID="bf554a2f-a035-4c22-bca8-162def35a03c" TYPE="ext4" 
/dev/sda2: UUID="7cb917ba-babb-42cd-897e-2070d540eda4" TYPE="swap" 
/dev/sdb1: UUID="AA64B45A64B42AC9" TYPE="ntfs" 
/dev/sdb2: UUID="F66E431C6E42D551" TYPE="ntfs" 
/dev/sdb3: UUID="75a0854b-8b6b-453f-8aec-2a081a1f19e3" TYPE="swap" 
/dev/sdb5: UUID="279a18da-130b-46dd-8b54-84da48eb445f" TYPE="ext4" 
/dev/sdb6: UUID="393cd35e-b827-4dea-acb5-2a66f2369dce" TYPE="swap" 
/dev/sdb7: UUID="cead26d6-08f4-4894-ac78-a9a4ce59f773" TYPE="ext4" 
/dev/sdb8: UUID="0cef2d59-21ca-4ba2-a9b2-0b9ef1f42589" TYPE="ext4" 

Here, the second column is full of Universal Unique Identifiers, that no matters where you plug them, they will be the same. Now, lets start modifying your fstab. I will take this partition as example:

/dev/sdd
Mount Point: /mnt/68787D0E787CDC6E
Identify As: /dev/disk/by-uuid/68787D0E787CDC6E

blkid should returns something like:

/dev/sdd1: UUID="68787D0E787CDC6E" TYPE="ntfs" 

In your fstab you should write:

UUID=68787D0E787CDC6E /media/some_directory               ntfs-3g    defaults,auto,users 0       0

(in this case it will mount at boot)

UUID=68787D0E787CDC6E /media/some_directory               ntfs-3g    defaults,noauto,users 0       0

(in this case it will mount only when you select the drive)

You should modify the UUID and the /media/some_directory fields as you see fit. Hope this aleviates your problem.

About the change of behavior, I don't found any problem with the layer. Maybe you hit a bug or something changed in your system.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.