Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 (precise) Kernel : 3.5.0-18-generic

I am encountering a strange problem, my whole desktop has shifted to right. This happened after I restored my system, I was getting a blank screen earlier.(something is better than nothing).

For some reason it also shows my display as laptop.enter image description here

Running xrandr

xrandr: Failed to get size of gamma for output default Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768 default connected 1024x768+0+0 0mm x 0mm
1024x768 0.0* 800x600 0.0 640x480 0.0

Running lspci

lspci -nn | grep VGA

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) My Display on window supports maximum of 1366*768. I do not want to reinstall everything please help.

It is cycled around as mentioned by Eliah Kagan For correcting my blank screen issue I edited my grub file I edited this line and added nomodeset, without it screen gets all grained up.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset "

When I boot from live CD also I get the same shifted screen

Update 2

Tried booting from live CD with 11.04 same issue

Update 3 .xsession-errors file : http://pastebin.com/uveSgNa8

Update 4

xrandr -q | grep -w connected

xrandr: Failed to get size of gamma for output default

default connected 1024x768+0+0 0mm x 0mm

share|improve this question
2  
It looks like the display is cycled around: panel applets that usually appear on the very right side of the top panel are on the left instead (in the full-size screenshot). When you move your mouse pointer to the right, past the right edge of the screen, does it appear on the left? Also, what did you do to restore your system from the black screen problem (and do you have any information about what caused that)? This seems like a bug but if you edit your question with more info we may know for sure. –  Eliah Kagan Aug 16 '13 at 12:51
    
We need to know what kind of graphics hardware you have in this machine. Can you include the output of lspci -nn | grep VGA in your question? –  Marius Gedminas Aug 19 '13 at 6:00
    
Added the information, is there any other anything else I should add –  Sunny Kumar Aditya Aug 19 '13 at 6:26
    
Looks like the background is the right size, did you try using the monitor buttons to try to re-center the screen? –  ubfan1 Aug 19 '13 at 22:03
1  
Can you add the output of the file: .xsession-errors herein? This should be in your /home directory as a hidden (the '.' character) file. THat should provide us with some diagnostic information. –  freecode Aug 21 '13 at 16:07
show 10 more comments

7 Answers

up vote 2 down vote accepted

The problem is resolved I was searching for why I was getting

Failed to get size of gamma for output default Screen

on running xrandr. I came across this post

http://ubuntuforums.org/showthread.php?t=1594308&page=2#16

and followed the steps mentioned there

The correct solution would be to set up an xorg.conf file with your resolution;could be done by Xorg -configure (little pain,because it includes the whole bunch of possible configuration options);so it might be worth to try an existing xorg.conf file from the web. Found this xorg.conf e.g. :

This was an interesting issue My desktop is normal now thanks to all who helped out.

share|improve this answer
add comment

Installing a proprietary video card driver might help by allowing you to move the area of the screen. At least the nvidia x-server settings app would allow you to do that if you have an nvidia card. Not sure about the AMD catalyst, though.

share|improve this answer
    
He uses intel, IMO there is no Inter proprietary drivers. –  Braiam Oct 3 '13 at 13:57
add comment

Do you have higher resolution settings available? If so try and set it to the highest settings you have... ↓

enter image description here

share|improve this answer
    
Its set at highest resolution setting that is 1024x768 –  Sunny Kumar Aditya Oct 24 '13 at 5:16
add comment

Did you try pressing "Auto Set" button on your monitor??
I once experienced the same problem.
But i got it solved just by pressing "Auto" button on my monitor...

share|improve this answer
add comment

I have a NVIDIA card and I went into the DASH> NVIDIA X Server Settings > X Server Display Configuration.

Then I set the default video input 1920x1080 (for me) and change the ViewPortOut to 1768x992+80+40. That lets me have my resolution but not screw anything up, when my Ubuntu bugged out to scroll the desktop when I moused to the bottom or the right of my screen this had changed and was my problem.

Sorry if it doesn't appy.

///EDIT: Sorry to modify this value click the "Advanced" Button on the bottom

share|improve this answer
add comment

Check the vbios of your computer by restarting and entering bios. Check video display and reset, adjust.

Printout the vbios if you have questions.

Did you say you tried to adjust the screen in in the front controlls?

share|improve this answer
    
where can I find vbios settings in bios ?? –  Sunny Kumar Aditya Nov 5 '13 at 7:21
    
F9 or F10 during bootup. –  Diogenes Lantern Nov 5 '13 at 17:19
add comment

Was your problem solved? If not... I see from your xsession-errors that the issue is in the EDID file from your monitor: "unable to get EDID for output"

FIRST SHOT

I had that when I tried to connect an external monitor from its VGA in to the HDMI port of my laptop using a VGA-to-HDMI conversor. It caused the problem. Then I switched to the DVI-D in of the external monitor and used a DVI-to-HDMI conversor. That solved my problem with the EDID thing. Maybe because the both signals were digital now... I don't know.

After that I had to do some tweaking on the screen's resolution (Ubuntu 12.04) as shown here.

SECOND SHOT

Try deleting the /home/$USERNAME/.config/monitors.xml file.

Type:

$ rm ~/.config/monitors.xml

That's a long guess for your problem, but who knows. Don't worry, this file is rebuild every time you save your Display Preferences.

THIRD SHOT

Type:

$ xrandr -q | grep -w connected

It shows which display is in use (e.g. LVDS1 or VGA1).

Then you can type:

$ xrandr --output LVDS1 --primary --auto

Note that you should change "LVDS1" to the according display in use.

Hope it works!

share|improve this answer
    
I can't try yours and @Diogenes solutions until this coming Tuesday :|. I will update as soon as possible –  Sunny Kumar Aditya Nov 2 '13 at 7:06
    
OK. Good luck! If my THIRD SHOT worked, you can make it permanent using the answer I've posted here. –  samuelcersosimo Nov 3 '13 at 16:39
    
added third's results to question's update 4, second does not work and first is yet to be tried. I will update. –  Sunny Kumar Aditya Nov 5 '13 at 7:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.