Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I've got the AskUbuntu chatroom (I'm just using this as an example, I've got other webapps that I've got the same issue with) saved as a "Application Shortcut" in Chromium, and the icon is really (And I mean really) low resolution. Example:

enter image description here

The top one is the default icon that's used for the Application Shortcut, the bottom is the AskUbuntu lens - so my question is, how can I use the icon that's used for the AskUbuntu lens.

enter image description here

share|improve this question

1 Answer 1

up vote 4 down vote accepted

With daily chromium builds and recent BAMF you can (if you look closer to that screenshot, you can see an example with my site and high-res icon). But in the current state of chromium you need to do some hacking to make it support this easily:

  • Make chromium generate a .desktop file for the application Menu too (if you don't want you to create one by scratch).
  • Get your chromium app window WM_CLASS with xprop | grep WM_CLASS | awk '{print $4}' (if it's just "Chromium Browser" or something similar you need to update chromium).
  • Edit that .desktop file (located into ~/.local/share/applications) with gedit or any other text editor; the file should contain:

    StartupWMClass=$APP_WM_CLASS_Found_on_step_2
    Icon=~/your/icon/file/name/or/path
    

    i.e. (for an app pointing to http://mail.google.com with google_mail.png in ~/.local/share/icons):

    StartupWMClass=mail.google.com
    Icon=google_mail.png
    
  • Restart bamfdaemon or unity at all; now when you'll run an application with that WM_CLASS the settings defined in the desktop file you've just edited will be used; icon included ;)

share|improve this answer
    
Been trying with no luck. :l Using Chromium nightly, and also using a Up-to-date Unity install. :( –  jrg Apr 4 '11 at 0:50
    
@James Gifford: the currently bamfdemon package available in natty has not updated yet. You need to compile it from bzr to get this working. –  Treviño Apr 4 '11 at 9:43
1  
@James, now bamfdaemon package in natty should be updated. Give it a try again! ;) –  Treviño Apr 6 '11 at 17:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.