Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i've got a Realtek wifi card about which Terminal says,

03:01.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8190 802.1

in my Dell Vostro 220. Windows 7 uses it fine, but Ubuntu can't seem to see it. i set up a wifi connection in the Network prefs but it doesn't show up in the drop-down network menu in the upper right corner of the screen. 99% of the questions i see asked about this online are answered either with questions or with instructions to go to System Settings -> Software & Updates -> Additional Drivers, where i imagine one is expected to find something but i find nothing - the box in that pref pane tab is empty.

i update the OS every time updates are reported and i last updated it about five minutes ago.

I've downloaded drivers from Realtek's site, but I'm new to Linux (and the ridiculous amount of work it requires you to do in order to accomplish the simplest tasks) and I have no idea which version of an archive to download nor what to do with all those files in the archive once i expand it.

can somebody help with this? preferably in some way i can understand without a degree in computer science? i want to use this OS, not spend the rest of my life learning how to make it function.

thank you.

share|improve this question

2 Answers 2

Most realtek drivers doesn't work out of the box.

Realtek doesn't provide a linux driver for this card :(

So we are left with two option

  • Use some driver that matches the hardware design
  • Use ndiswrapper (using windows driver in linux, I would never recommend it if it not the last resort.

According to this answer , you can use r8168 driver with it.

So based on that answer, download the latest driver package from

http://r8168.googlecode.com/files/r8168-8.036.00.tar.bz2

Now open a terminal, say you saved the package to Downloads folder, so change directory to it

cd Downloads

Next unzip the package, tar -xjf r8168-8.036.00.tar.bz2

Change dir, cd r8168-8.036.00

Now run the installer, sudo ./autorun.sh

Please let me know if it works. If it fails with some error message also include it.

share|improve this answer
    
thank you. your instructions worked and Terminal returned no error messages, but i've restarted my machine and deleted and recreated a wifi connection in the Network Connections pane and nothing seems to have changed. there's still no wifi option in the Network preferences, and the wifi network connection i added doesn't work any better now than it did before. neither is there anything in the "Additional Drivers" pane. got any other ideas? either way, i appreciate your time. thanks. –  user184510 Aug 16 '13 at 6:25
    
apparently ndiswrapper is already installed. would that be causing problems? –  user184510 Aug 16 '13 at 6:56
    
you know what? never mind. i just went to download a driver for my printer and the simple act of installing a printer driver is incomprehensible to me. i don't need this. i don't like the directions Apple's been going with the Mac OS lately, but at least on the Mac i don't have to spend a week deciphering the instructions for installing a printer driver. i click shit and it's done. when Linux is ready to actually be used, which it might be in another century or two, i'll have another look at it. but in this lifetime i have far better things to do. –  user184510 Aug 16 '13 at 7:23

I had the same problem. My way around it was to get my old Linksys wireless router and install Tomato firmware on it " http://www.polarcloud.com/tomato " , connect to it through my NIC and configure the router as a wireless client and connect it to my wireless network that way. If you dont have a old Linksys router, you can check your local goodwill store, last time I was in one by me I saw 4 in there for about $5 each.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.