Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have followed the example listed earlier on how to create a shared directory between Ubuntu and Window 7, but stuck at step 6 in the following link below.

Sharing between Host and Guest in Virtualbox

Repeat again here:

I have tried to follow the above example, but stuck at step 6, where a command "sudo mount -t vboxsf virtual ~/virtual" is issued.

I just want to clarify a couple things in the above example just to be sure: For the mount command, 1) "virtual" is the directory that needs to be created in Window 7, right? Where should I put this file on host Window 7? If it's desktop, do I need to specify the absolute/relative path? If so, how?

2) Should "~/virtual", the shared directory, be located in the home directory of Linux (guest) machine?

I tried the above command with "virtual" at Desktop, and ~/virtual" at Linux home directory, but got the following errors:

phil-VirtualBox:/:~$sudo mount -t vboxsf LDDI ~/LDDI [... errors ...] /sbin/mount.vboxsf: mounting failed with the error: Protocol error

Please, am I missing something here?

Ubuntu: 12.04 LTS

VirtualBox: 4.2.14

Please let me know if I am doing something wrong.

Thanks,

Phil

share|improve this question
1  
I think that example is for a virtual (guest) Ubuntu session with an Ubuntu host. I'm not sure if it's different in your case. Which is the host and guest for you? –  Sparhawk Aug 16 '13 at 1:06
    
Host is Window 7 and Guest is Ubuntu. One required additional command seems to do the trick for me: sudo mount -t vboxsf shared-dir /home/username/shared-dir. –  Phil Aug 16 '13 at 1:30
    
I mistakenly mounted the directory with the content in it. Now the directory contents are gone. Wonder if the lost directory content can be recovered anymore? The lost contents are not that important, but I am just curious if recovery is possible. Thanks for your help. –  Phil Aug 16 '13 at 1:40
    
I found out that I needed to add one more command (stumbled upon this command while leafing through askubuntu for my problem) for it to work: sudo usermod -g vboxsf <user-name-id> –  Phil Aug 16 '13 at 2:15
2  
Related: askubuntu.com/questions/30396/… –  Takkat Aug 16 '13 at 7:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.