Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have had a problem with suspending my computer, since I installed Ubuntu 12.04 LTS a month ago, dual boot with a Windows 7 system.The "suspend" function does not work.Whenever I suspend my system and then turn it on again, it just starts from the beginning, as if I had not suspended it, but shut it down.

No open programs or documents are resumed where I left it.The same goes for hibernating my Windows 7 system, which behaves as if it underwent a forced shutdown, whenever I try to resume from hibernating.

Since both systems have this problem, I think the latter lies in GRUB.When I installed Ubuntu, I was kept too long on the installation screen after it was complete and, thinking it had frozen, I forced it to shutdown to start the new system. However, apparently the installation was not completely done, as I got a GRUB error after that, being unable to boot any system. I fixed it by running a GRUB fixing program through the Ubuntu Live CD, the name of which I cannot recall.Perhaps that program did not solve all the problems.

I have no further problems with Ubuntu so far. I had a Linux Mint installation before that,instead of Ubuntu, with no such problem.Can you suggest a way to fix this?

share|improve this question
    
I'm confused, is the problem with suspend or just with hibernation? –  Braiam Aug 15 '13 at 11:49
    
Well I have problem with suspending too.I don't even have the option for hibernating, as I noticed after the answer I received, since I have no swap partition.I just posted another question here hoping to find a specialised solution on the matter. –  Noob Doob Aug 15 '13 at 11:54

1 Answer 1

up vote 3 down vote accepted

To hibernate a linux system your swap area must be able to hold up all of your ram (or what's in it), check that in the first place. On windows it's similar but you need disk space. Although it may also be some hardware issue but it's really hard to tell with amount of data you have provided. Chceck your system logs for what might have gone wrong. (in ubuntu you'll find them in /var/log)

share|improve this answer
    
You pointed me to the right direction.That should do.As I can remember I had set swap to 0 in Ubuntu, and that might have been the case in Windows too. –  Noob Doob Aug 15 '13 at 11:35
    
To explain my self:I had a bad experience with an old computer,Windows XP, where having a swap file and thus using the hard disk constantly while working would slow it down to the point of freezing.I have enough RAM for my tasks on my current system, so I put swap to 0, without having the suspension in mind, and I did not think of that either after I saw the problem, being misleaded from my impression about GRUB.Having the core of the problem pointed out, I will now consider it and adjust whatever I have to ,according to my needs. –  Noob Doob Aug 15 '13 at 11:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.