Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just upgraded to ubuntu 13.04 with kernel 3.10.6. After that I have updated my fglrx to 13.8 beta and after that I have added ppa:kubuntu-ppa/backports and I have upgraded my system. After reboot my effects settings changed to xrander, so I tried to apply new opengl 2.1,2.0 and 3.1 but none of them works. It says that "it was not possible to activate effects using those options, check the X configuration or change the options about the composition type".

Here is my xorg.conf: http://pastebin.com/raw.php?i=D6MPUEZv

and my Xorg.0.log: http://pastebin.com/raw.php?i=nXF80qmH

This is the output of glxinfo:

name of display: :0
Setting of real/effective user Id to 0/0 failed
libGL error: open uki failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
display: :0  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: ATI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
client glx vendor string: ATI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_swap_control, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_MESA_allocate_memory, GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_NV_swap_group, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_swap_barrier, GLX_SGIX_swap_group, GLX_SGIX_visual_select_group,
    GLX_EXT_texture_from_pixmap, GLX_EXT_framebuffer_sRGB,
    GLX_ARB_fbconfig_float, GLX_AMD_gpu_association, GLX_EXT_buffer_age
GLX version: 1.4
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
    GLX_EXT_texture_from_pixmap
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 6800 Series
OpenGL version string: 2.1 (4.3.12438 Compatibility Profile Context 13.20.5)
OpenGL shading language version string: (null)
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
    GL_ARB_fragment_program_shadow, GL_ARB_imaging, GL_ARB_multisample,
    GL_ARB_multitexture, GL_ARB_occlusion_query, GL_ARB_point_parameters,
    GL_ARB_point_sprite, GL_ARB_shadow, GL_ARB_shadow_ambient,
    GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_texture_non_power_of_two, GL_ARB_texture_rectangle,
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
    GL_ARB_vertex_program, GL_ARB_window_pos, GL_ARB_shader_objects,
    GL_ARB_vertex_shader, GL_ARB_fragment_shader, GL_ARB_framebuffer_object,
    GL_ARB_geometry_shader4, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_copy_texture,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
    GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
    GL_EXT_subtexture, GL_EXT_texture3D, GL_EXT_texture_compression_s3tc,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, GL_EXT_texture_lod,
    GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
    GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
    GL_EXT_histogram, GL_EXT_framebuffer_blit, GL_EXT_framebuffer_multisample,
    GL_EXT_geometry_shader4, GL_EXT_gpu_shader4, GL_ATI_draw_buffers,
    GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
    GL_ATIX_texture_env_combine3, GL_IBM_texture_mirrored_repeat,
    GL_INGR_blend_func_separate, GL_SGIS_generate_mipmap,
    GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
    GL_SGIS_texture_lod, GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays,
    GL_ARB_texture_float

and this is the output of fglrxinfo:

Setting of real/effective user Id to 0/0 failed
libGL error: open uki failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
display: :0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 6800 Series
OpenGL version string: 2.1 (4.3.12438 Compatibility Profile Context 13.20.5)

How can I solve it? Thanks

share|improve this question

5 Answers 5

Your drivers are corrupted - there's a lot of bugs in 13.8, such as lack of access rights to procfs / proc / ati / ... are patches on it, but these drivers are highly "inappropriate" for example, memory leaks, etc.. : P I would recommend for now 13.3 beta3 - by our NeteXt'73 - I built Catalyst 13.3 beta3 v4 so, and would ideally operate under 3.10.x kernels, and my v25.x

http://ubuntu.pl/forum/viewtopic.php?f=216&t=163378

As to the KDE 4.11, have researched this situation - it looks like a bug in KWin.

share|improve this answer
    
ok it was not a kwin but, I have removed fglrx 13.8 and kernel 3.10. Now I have fglrx 13.4 stable and kernel 3.8 and everything works, also new kwin opengl v3.1. So I will try NeteXt'73 driver 'cause as you said it works with kernel 3.10.x, thanks –  Frank Aug 19 '13 at 8:25

I had the same problem with 3.10 kernel, fglrx 13-8 beta, and kde 4.11. Here is what worked:

Run the driver installer with the extract option:

./amd-catalyst-13.8-beta1-linux-x86.x86_64.run --extract [dirname]`

Then cd [dirname] and open file "common/lib/modules/fglrx/build_mod/firegl_public.c". Find line 821 or 822. Change:

root = KCL_create_proc_dir(NULL, "ati", S_IFDIR);  

...to:

root = KCL_create_proc_dir(NULL, "ati", S_IFDIR|S_IRUGO|S_IXUGO);  

Then run this and reboot:

sudo ./ati-installer --arguments --install  

...or rebuild deb packages, install them then reboot:

sudo ./ati-installer --arguments --buildpkg Ubuntu/raring  

Source: http://phoronix.com/forums/showthread.php?82948-AMD-Catalyst-13-8-Beta-Driver-For-Linux-Released/page6

share|improve this answer
    
thanks, I finally can see a complete explanation of the patch installation thanks. but maybe it would be better to wait for a stable release –  Frank Aug 19 '13 at 8:27
    
i can confirm that this has cleared up all issues for me and has allowed me to run cinnamon: 13.04, 3.10, HD8400. ty! –  user128334 Aug 31 '13 at 15:09

Had the same problem (fglrx 13.4 / kubuntu 13.04 / kde 4.11 / kernel 3.8.0-29).

After reinstalling fglrx-updates package (from ubuntu repository) AND

sudo aticonfig --initial --force

and restart OpenGL worked again for me.

share|improve this answer

I can confirm this issue on my kubuntu 12.04 installation using the backports repository. I'm using the fglrx-driver which was suggested by jockey (I will post more information, when I'm at work tomorrow).

I previously ran 4.10 without having any problems. After receiving th 4.11 Update my Desktop effects (Opengl) won't run anymore. Working without effects I get a lot of fractals when I change size or doing somethin similar.

As intermediate solution I installed gnome shell. Mutter does not seem to have a problem with the fglrx driver due 3d is working as expected here.

Any suggestions what I can do?

Thanks

share|improve this answer

Confirming same under KDE(buntu) 13.04 over 3.9 kernel + catalyst 13.8 beta driver on AMD A10 6800 APU with ATI Richland [Radeon HD 8670D] on 3 screens, one X, no xinerama.

I managed to have OpenGL running after dome voodoo dancing, not sure what helped in the end. Worked quite fast and nice, but there were problems with mentioned above fractals and crushing plasma.

I switched to XRender then, and it seem to be fine so far. Few effects not working though, but most of them do. The only drawback is that GTK apps run little slow (these do run fast under OpenGL).

Another issue was KWin and plasma-desktop eating CPU, but that was resolved by removing "System monitor" widget.

Thanks for updating your post, I will try roll back to 3.8/13.4 too, when I need OpenGL.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.