Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

When I go into the setup utility I have the options: Main, Security, Diagnostics, System Configuration, Exit

This is different from what I've seen online when trying to find a guide.

But, in the System Configuration option I have a Boot Options section. So, I click that. I have a Boot Order option, so I click that. I get the options: USB Diskette on Key/USB Hard Disk, Notebook Hard Drive, USB CD/DVD ROM Drive, ! USB Floppy, ! Network Adapter

I tried selecting the USB Diskette on Key/USB Hard Disk but when I restart it tells me "BOOTMGR is missing, restart"

I am at a loss. Help!

Thanks in advance. <3

share|improve this question
Please provide more information like are you Using Windows 8, in UEFI mode? – Aaditya Bagga Aug 15 '13 at 9:00

3 Answers 3

up vote 1 down vote accepted

If you are using Windows 8 in UEFI mode, you need to press F9 (for HP Laptops) to select your boot device, and you have to select an option like `USB Diskette on Key/USB Hard Disk (EFI mode)

Also you may need to disable the secure boot option from your Bios Menu, it would most probably be present under the System Configuration tab.


Also Enable Booting From USB


Disable Fast StartUp

from your BIOS Menu.

You may also need to Disable Secure Boot from the BIOS Menu as well.

To Bring Up the BIOS menu, press F10 while booting( for HP Laptops)

Note-- You can check if you are running UEFI mode by going to the system bios by pressing F10 and checking under the System Configuration tab.

If you are facing any problems please let us know.

share|improve this answer
Sorry, I'm using Windows 7 in UEFI. When I hit F9 I get "Boot Option Menu - Notebook Hard Drive," but that's it. I connected the flash drive to my desktop and it shows that it's properly set up as a boot disc. (see: ) – user184249 Aug 15 '13 at 15:45
Yeah looking at your screenshot your USB Drive seems to be correct, however i think that booting from USB is not enabled. To enable it, fit F10 to bring up the BIOS setup while booting, and probably in the Boot or System Configuration Tab, there would be an option like- ENABLE Booting from USB. Tick it. There would also be an option like- FAST STARTUP, disable it. Now i think you would be able to boot from the USB Drive. Keep Us posted. And if my answer helped you, please mark it as solved if you successfully boot from the USB. :) – Aaditya Bagga Aug 15 '13 at 15:57
Perhaps it may be that you are not using UEFI mode, because I also have a HP Laptop in UEFI, and it displays several options like Boot from EFI file besides the NoteBook HardDrive Option. – Aaditya Bagga Aug 15 '13 at 16:20
And If you wanted to boot from a Live DVD, you will also have to Enable Boot from Optical DIsk in your BIOS menu. – Aaditya Bagga Aug 15 '13 at 16:21
It's potentially just BIOs. I'm not entirely sure what the differentiating aspects are, but I don't have a Boot option. The laptop doesn't have a disc drive, which is why I'm trying to use a USB stick. – user184249 Aug 15 '13 at 16:22

I've just bought HP TouchSmart today, there are no ticks like "Enable booting from USB" or "fast startup". So non of these advices worked. What helped is - to enable "legacy support" and only then USB installer became available

share|improve this answer

Not sure if anyone is still in need of help with this, but all you have to do is:

  1. Press esc on start up
  2. Press F11
  3. Select recover from CD/usb then install Ubuntu
share|improve this answer
I love that you get to the point quickly, and cut right to the chase, but if you could maybe provide a bit more explanation, what to do in other situations, add in the stuff after the initial answer that helps in a variety of situations instead of just this one. Welcome to the site and I hope to see even more content from you in the future! (both meanings included, pun both intended...and not) – sbergeron May 8 at 18:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.