Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running my apt-get in a normal way but today I got some errors while using the apt-get command can anyone suggest any enhancement that I need to make in my configuration files to fix it. I have run this command

$ sudo apt-get install firefox

or before also I tried to update the packages using

$ sudo apt-get update

but I got this error:

/usr/sbin/update-info-dir: line 51: rm: command not found
dpkg: error processing install-info (--configure):
 subprocess installed post-installation script returned error exit status 127
Errors were encountered while processing:
 install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question

closed as off-topic by Seth, Eric Carvalho, Eliah Kagan, Kevin Bowen, RolandiXor Aug 19 '13 at 16:25

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Seth, Eric Carvalho, Eliah Kagan, Kevin Bowen, RolandiXor
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Have you tried sudo dpkg --configure -a and/or sudo apt-get install -f? –  Alvin Row Aug 15 '13 at 4:32
    
Both the commands give the same error stated in the question above. –  Chitrank Dixit Aug 15 '13 at 4:48
    
What's the result of which rm and sudo which rm? –  Braiam Aug 15 '13 at 21:53
    
for which rm I have got the path /bin/rm –  Chitrank Dixit Aug 15 '13 at 21:58
1  
Related (not necessarily a duplicate): Problem with install-info during apt-get update and install Really, this should be reported as a bug in the install-info package (but please read that first and search to see if it's already been reported). When you report the bug (assuming you choose to do so), start the process with ubuntu-bug install-info. –  Eliah Kagan Aug 18 '13 at 18:54

Browse other questions tagged or ask your own question.