Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a toshiba satellite computer... I have ubuntu 13.04 installed and my wifi is lower than what it is when I had windows 8. I was wondering if there was some way that I could fix it so I could have a better connection... any help would be greatly appreciated

share|improve this question
1  
do you mean that the signal strength appears lower, or that the connection itself is slower? –  amc Aug 15 '13 at 2:00

2 Answers 2

Some things to consider.

The connection could "appear" to be worse due to the way the icon displays your connection. You might want to check your actual ping response times and your connection rate to see if it is in fact worse. Open a terminal and issue command

iwconfig

and look for bitrate, and command

ping -c 4 192.168.1.1

(or whatever your router IP address is) and check your response times (you will probably want something in the neighborhood of 5ms or less over wireless). Is it running slowly for you?

If it is, Ubuntu may be using a generic driver where there is a better driver provided by the wireless chip manufacturer. That is something you might want to determine from the system specs of your particular model computer.

More information concerning your PC's model name/number and your actual connection rates might help pin down a better answer.

share|improve this answer

I had the same problem with one of my friend's toshiba satallite with Atheros wireless device.Some wifi drivers for ubuntu 13.04 manages a power management scheme. This power management helps increasing battary life by limiting power for the wifi adapter by reducing the performance of your adapter. When you run

iwconfig

you might see a line in the output saying

Power Mangement: On

If it says so, that is your problem. You can solve it running the following command.

sudo iwconfig wlan0 power off

*replace 'wlan0' with your interface name

To make this permanent, you can include this command as a shell script in the folder

/etc/pm/power.d

To do this follow given steps,

cd /etc/pm/power.d
sudo nano wifi_pwm

In the editor, include followings in the newly created file.

#!/bin/sh 
/sbin/iwconfig/ wlan0 power off

Save your file with Ctrl + O and exit with Ctrl + X.

Reboot your machine, then you will turn off power management permanently.

share|improve this answer
    
Thanks @chili555, I edited the answer with new steps. –  Deepal Aug 15 '13 at 17:15
    
Since the sequence above is now persistent, I will delete my comment above. –  chili555 Aug 15 '13 at 20:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.